Photo posting help please - Page 2 - Escape Trailer Owners Community

Go Back   Escape Trailer Owners Community > Escape Community > Forum Help | Announcements | Suggestion Box
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 08-30-2015, 11:47 PM   #11
Senior Member
 
gbaglo's Avatar
 
Join Date: Oct 2008
Location: North Vancouver, British Columbia
Trailer: 2009 Escape 17B - "Toad". '08 Toyota RAV4 V6
Posts: 10,716
Not sure if this will help. It describes how to lock the screen ( and I think the image ) so that if you rotate it in your photo app it will stay that way.
Have a look and see if it makes sense to you.

How can I stop iPad screen rotation / lock the accelerometer? | The iPad Guide
__________________

__________________
2009 Escape 17B "Toad"
2008 Toyota RAV4 V6 Sport
North Vancouver, British Columbia

What happens to the hole when the cheese is gone?
- Bertolt Brecht
gbaglo is offline   Reply With Quote
Old 08-31-2015, 12:19 AM   #12
Senior Member
 
rbryan4's Avatar
 
Join Date: Jun 2014
Location: San Antonio, Texas
Trailer: 2015 19 "Past Tents", 2015 F150 Ecoboost
Posts: 7,570
Lotar and Wendy, the problem is that forums strip the metadata from a photo. The metadata controls how the photo is oriented. The photo will always appear in the forum in its raw orientation. This holds true for phone cameras as well as most digital cameras.

The metadata is there so that the photo can automatically be viewed right side up on the device it was taken with. There is a very easy way to solve this problem:

Always take photos in landscape mode.
If it was taken in portrait mode, upload the photo to a computer, then rotate it to landscape mode and save it.
Upload to the forum and voila! Right side up.
__________________

__________________
"You can't buy happiness, but you can buy an RV. And that is pretty close."
rbryan4 is offline   Reply With Quote
Old 08-31-2015, 12:29 AM   #13
T&R
Senior Member
 
Join Date: Dec 2014
Location: Medford, Oregon
Trailer: "Olaf" 2015 21'..... 2015 Tundra CrewMax
Posts: 110
You may be able to rotate your picture on your iPhone before uploading. At least with a 5s & iOS 7 I can. But I rarely take pictures or movies in portrait.

Here's an entertaining public service announcement about VVS, which specifically pertains to movies, but applies to still pictures as well.

https://youtu.be/Bt9zSfinwFA
T&R is offline   Reply With Quote
Old 08-31-2015, 12:41 AM   #14
Senior Member
 
gbaglo's Avatar
 
Join Date: Oct 2008
Location: North Vancouver, British Columbia
Trailer: 2009 Escape 17B - "Toad". '08 Toyota RAV4 V6
Posts: 10,716
Quote:
Originally Posted by rbryan4 View Post
Always take photos in landscape mode.
If it was taken in portrait mode, upload the photo to a computer, then rotate it to landscape mode and save it.
Upload to the forum and voila! Right side up.
Makes no sense to me to shoot a picture of the Empire State Building in landscape mode. There is another solution. I just don't know what it is.
I just shot this picture on my iPhone as a vertical ( portrait mode ) and mailed it to myself. I exported it from my mail to my desktop, and it is still vertical. And now, I will post it.
So, what's the problem? I sure don't know. I didn't rotate it in any program. Didn't have to.
Attached Images
File Type: jpg iPhone Vertical.jpg (149.1 KB, 4 views)
__________________
2009 Escape 17B "Toad"
2008 Toyota RAV4 V6 Sport
North Vancouver, British Columbia

What happens to the hole when the cheese is gone?
- Bertolt Brecht
gbaglo is offline   Reply With Quote
Old 08-31-2015, 01:39 AM   #15
Senior Member
 
Join Date: Dec 2012
Location: Edmonton, Alberta
Trailer: 1979 Boler B1700
Posts: 9,039
Quote:
Originally Posted by gbaglo View Post
I just shot this picture on my iPhone as a vertical ( portrait mode ) and mailed it to myself. I exported it from my mail to my desktop, and it is still vertical. And now, I will post it.
So, what's the problem? I sure don't know. I didn't rotate it in any program. Didn't have to.
I fully expected the image to be in the wrong orientation, but it's not... it displays in portrait (as intended) in the forum (viewed with Chrome) and the downloaded (to a Windows PC) image is in portrait, as confirmed in IrfanView.

Are the people having problems using the mobile app to upload? I assume the above was uploaded for posting in a web browser on that Mac.

The iPhone image may be converted to display normally in preparation for e-mailing, by the email app.
Brian B-P is online now   Reply With Quote
Old 08-31-2015, 01:43 AM   #16
Senior Member
 
gbaglo's Avatar
 
Join Date: Oct 2008
Location: North Vancouver, British Columbia
Trailer: 2009 Escape 17B - "Toad". '08 Toyota RAV4 V6
Posts: 10,716
It was posted from my Mac, using Firefox. I've never used the app on my iPhone. I downloaded the FGRV app for iPhone and don't use it either. Tried it, didn't like it.
I suspect you are correct and the issue is with the app. If I had it on my phone, we could test it, I guess.
I would suggest somebody that has the app on their phone, read the link in post #11 and try to lock their phone and then post.
__________________
2009 Escape 17B "Toad"
2008 Toyota RAV4 V6 Sport
North Vancouver, British Columbia

What happens to the hole when the cheese is gone?
- Bertolt Brecht
gbaglo is offline   Reply With Quote
Old 08-31-2015, 05:41 AM   #17
Senior Member
 
Join Date: Oct 2014
Location: Juneau, Alaska
Trailer: 2015 17A - Ready for 4th Maiden Voyage
Posts: 594
Best solution is to get an Android phone .....

Just kidding ....... I really appreciate all the pictures everyone has been sending in. Thank you
__________________
Progress is man's ability to complicate simplicity.
Thor Heyerdahl
StarvingHyena is offline   Reply With Quote
Old 08-31-2015, 12:03 PM   #18
Site Team
 
Janet H's Avatar
 
Join Date: Sep 2012
Location: Pacific NW, Washington
Trailer: 1964 Globetrotter
Posts: 445
This isn't a new issue and it plagues mobile device users. Your phone automatically rotates images when you view them to the proper orientation but when you load them to the forum, they display in the actual orientation they were shot in.

On my phone I can even use the phone upside down and the images appear normal when viewed on the phone. If I add them to a forum post however, they will be upside down as they were actually taken with an upside down camera.

As noted earlier, to correct this you need to import the image to a photo editor or app and correct the image.
__________________
.
You have brains in your head. You have feet in your shoes.
You can steer yourself any direction you choose | Dr. Seuss


Escape Forum Custom Google Search
Janet H is offline   Reply With Quote
Old 08-31-2015, 03:25 PM   #19
Senior Member
 
Join Date: Mar 2015
Location: Vancouver Island, British Columbia
Trailer: 2012 Escape 17B, 2011 Ranger FX4
Posts: 160
The photos in question (17B bunk support thread) were taken in portrait mode on an iPhone, were emailed & saved to my desktop computer, where they appear & are saved in portrait mode.

When uploaded to forum, appear rotated 90 degrees counterclockwise.

Opened photos in MS Picture Editor, rotated them 90 degree clockwise, saved them.

When the rotated/saved photos are uploaded to the forum, appear rotated 180 degrees!

Metadata, indeed!

I'll just either shoot iPhone in landscape, and/or shoot forum photos with the Canon (& see what happens!).

Happy trails.
__________________

__________________
Lotar & Wendy
"Sit loosely in the saddle of life" (Robert Louis Stevenson)
maurerl is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






» Virginia Campgrounds

Reviews provided by



All times are GMT -5. The time now is 11:38 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 Social Knowledge, LLC All Rights Reserved.