No luck winterizing - Escape Trailer Owners Community

Go Back   Escape Trailer Owners Community > Escape Tech > Escape Systems | Water, Waste, Charging & Propane
Click Here to Login

Reply
 
Thread Tools Display Modes
 
Old 10-19-2016, 06:56 PM   #1
Senior Member
 
float5's Avatar
 
Join Date: Nov 2010
Location: Denison, Texas
Trailer: 2015 21'; 2011 19' sold; 4Runner; ph ninezero3 327-27ninefour
Posts: 5,156
No luck winterizing

We went to winterize and the pump would not draw any anti-freeze. It seems that the water pump had not been working well but we're not sure we didn't goof up on something else.

We have the tube still connected, for winterizing, to the pump from last year. We turned the bypass valves. Had the tube in an anti-freeze jug. Were doing the exterior shower first and had it on and water came out of the shower hose but no anti-freeze would come out of the jug. Last year no problem. Ran the pump some time and nothing coming out of that jug.

We did everything else. Water heater drained. Water out from behind screen at city water. Anti-freeze down traps and toilet. Some water came out of faucets when running pump so I expect there really is not a problem with the lines. But even if not, still left with that toilet valve.
__________________

__________________
Cathy. Floating Cloud
"Live in the sunshine, swim the sea, drink the wild air.... "
Emerson
float5 is offline   Reply With Quote
Old 10-19-2016, 06:59 PM   #2
Senior Member
 
PGDriver's Avatar
 
Join Date: Nov 2008
Location: Southern Alberta, Alberta
Trailer: 2015 Escape 5.0TA
Posts: 1,657
There should be a valve where the winterizing tube connects by the water pump, turn the valve to select the winterizing hose. It should be at 90* to the water line.
Cheers
Doug
__________________

__________________
Cheers
Doug
PGDriver is offline   Reply With Quote
Old 10-19-2016, 07:06 PM   #3
Senior Member
 
float5's Avatar
 
Join Date: Nov 2010
Location: Denison, Texas
Trailer: 2015 21'; 2011 19' sold; 4Runner; ph ninezero3 327-27ninefour
Posts: 5,156
Quote:
Originally Posted by PGDriver View Post
There should be a valve where the winterizing tube connects by the water pump, turn the valve to select the winterizing hose. It should be at 90* to the water line.
Cheers
Doug
That is probably it! We don't remember turning that from last year. In fact, we don't even know if the tube was already there for winterizing by Escape but think it was. We will look for the valve. Not at the trailer now. Thank you so much.
__________________
Cathy. Floating Cloud
"Live in the sunshine, swim the sea, drink the wild air.... "
Emerson
float5 is offline   Reply With Quote
Old 10-19-2016, 07:31 PM   #4
Senior Member
 
float5's Avatar
 
Join Date: Nov 2010
Location: Denison, Texas
Trailer: 2015 21'; 2011 19' sold; 4Runner; ph ninezero3 327-27ninefour
Posts: 5,156
Thought this was a water pump problem so under wrong category. Maybe someone wants to move it.
__________________
Cathy. Floating Cloud
"Live in the sunshine, swim the sea, drink the wild air.... "
Emerson
float5 is offline   Reply With Quote
Old 10-19-2016, 07:48 PM   #5
Senior Member
 
PGDriver's Avatar
 
Join Date: Nov 2008
Location: Southern Alberta, Alberta
Trailer: 2015 Escape 5.0TA
Posts: 1,657
Don't forget to turn it back otherwise it won't draw water out of the fresh water tank.
Cheers
Doug
__________________
Cheers
Doug
PGDriver is offline   Reply With Quote
Old 10-22-2016, 03:17 PM   #6
Senior Member
 
float5's Avatar
 
Join Date: Nov 2010
Location: Denison, Texas
Trailer: 2015 21'; 2011 19' sold; 4Runner; ph ninezero3 327-27ninefour
Posts: 5,156
Well, this is what we think we did last year for anyone else's use. Found photos from last year of valves we turned when winterizing: two. Apparently, we turned the valve for winterizing and one of the other valves, the one near the floor. We thought we only had two valves to turn but there are three. Husband had no recollection of turning a valve for winterizing and neither did I, apparently because we thought it was a hot or cold water valve.

We did not use six gallons of anti-freeze or near that last year so did not fill the hot water tank. Seems we missed a valve though. Got all three this year.


On the 19', we had only had two valves to turn. 21' came with winterizing tube already on the water pump as we had ordered it. We previously did not run anti-freeze through the pump.
__________________

__________________
Cathy. Floating Cloud
"Live in the sunshine, swim the sea, drink the wild air.... "
Emerson
float5 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Escape Trailer Industries or any of its affiliates. This is an independent, unofficial site.



All times are GMT -5. The time now is 12:00 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2012 Social Knowledge, LLC All Rights Reserved.