RMD 8555 120 VAC issue - Escape Trailer Owners Community

Go Back   Escape Trailer Owners Community > Escape Tech > Escape Systems | Water, Waste, Charging & Propane
Thread Tools Display Modes
Old 10-03-2015, 07:24 PM   #1
Senior Member
padlin's Avatar
Join Date: Sep 2009
Location: Southwick, Massachusetts
Trailer: 5.0 TA #6, 2012 F150 EB
Posts: 2,657
RMD 8555 120 VAC issue

Looking for some suggestion if anyone has any.

Problem... 2 weeks into trip, fridge been working fine on all inputs. Changed from battery after a days drive to 120 VAC. About an hour later the freezer was up in the mid 20's from mid teens, fridge from high 30's to mid 40's, had not been opened. Could find nothing wrong, toggled breaker just for giggles. Swapped to gas.

A few days later I tried going from gas to 120 VAC, same thing, within an hour it climbed close to 10 degrees. Back to gas.

Can't mess around too much as the fridge is in use and we are nowhere near home. I do have some tools and a meter, but I'm not going to pull the unit. Unless I come up with something to try I'm just going to run it on gas.

Day temps have been hot, at least to us, mid 80's to 100. Both occasions above were with the air conditioner running so the inside temps were low 70's. Sun was not on the fridge side. Power Monitor showed no issues.
Happy Motoring
padlin is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by

All times are GMT -5. The time now is 08:48 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Copyright 2012 Social Knowledge, LLC All Rights Reserved.