5.0TA Power Jack problem - Escape Trailer Owners Community

Go Back   Escape Trailer Owners Community > Escape Tech > Problem Solving | Owners helping each other
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 03-18-2017, 05:07 PM   #1
Senior Member
 
Join Date: Feb 2015
Location: Bluffton, South Carolina
Trailer: 2014 Escape 5.0TA
Posts: 135
5.0TA Power Jack problem

The roadside power jack on our 2014 5.0TA no longer gets power. Curb side works as before. Would it be a bad switch? I pulled them out and wires and connections seem to be the same on both sides. I'm electrically incompetent.
Any suggests would be helpful.
Thanks,
David
__________________

D&R_SC is offline   Reply With Quote
Old 03-18-2017, 05:25 PM   #2
Senior Member
 
escape artist's Avatar
 
Join Date: Oct 2008
Location: St. Thomas not BVI., Ontario
Trailer: 2014 Escape 5.0TA / 2016 Ram Eco Diesel 4X4
Posts: 6,230
Quote:
Originally Posted by D&R_MA View Post
The roadside power jack on our 2014 5.0TA no longer gets power. Curb side works as before. Would it be a bad switch? I pulled them out and wires and connections seem to be the same on both sides. I'm electrically incompetent.
Any suggests would be helpful.
Thanks,
David
Hi: D&R-MA... Not sure if the inline fuses in the wires running just inside the access door to the switches are for the jacks. I can be just as shocked as the next guy!!! Alf
escape artist N.S. of Lake Erie
__________________

__________________
Quote Bugs Bunny..."Don't take life too seriously, none of us get out of it ALIVE"!!!
'16 Ram Eco D. 4X4 Laramie Longhorn CC & '14 Escape 5.0TA
St.Thomas (Not the Virgin Islands) Ontario
escape artist is offline   Reply With Quote
Old 03-18-2017, 05:52 PM   #3
Senior Member
 
Join Date: Jul 2014
Location: Somewhere, Florida
Trailer: 1804 Schooner
Posts: 1,642
David - Have you used a meter to see if the switch in question is getting power? Or you can pop the assembly out by prying it into the storage compartment in which it is located, and flip the wires around. If either case, you will be able to tell if it is a bad switch.
You might also want to pull the panel that provides access to the jacks. To do so, you will have to remove the propane tanks. The panel should be held in by six screws. Once it is removed, and the space to work is not great, use a mirror and see if to can locate a screw on the top of the jack. If you can, tighten it as best as you can. It is the ground for the jack. I know another member who had a problem with this on orientation/pickup day. It took Reace a couple of hours to figure out what was wrong. I'm not saying this is the cause, but it is worth checking. And we all know what Donna says about rolling earthquakes; all that vibration could have cause it to loosen.
__________________
“Quoth the Raven, ‘Nevermore’......” E. A. Poe
C&G in FL is offline   Reply With Quote
Old 03-18-2017, 06:29 PM   #4
Senior Member
 
Join Date: Feb 2015
Location: Bluffton, South Carolina
Trailer: 2014 Escape 5.0TA
Posts: 135
Quote:
Originally Posted by escape artist View Post
Hi: D&R-MA... Not sure if the inline fuses in the wires running just inside the access door to the switches are for the jacks. I can be just as shocked as the next guy!!! Alf
escape artist N.S. of Lake Erie
Checked those two fuses and they appear to be ok.
Thanks Alf
D&R_SC is offline   Reply With Quote
Old 03-18-2017, 06:32 PM   #5
Senior Member
 
Join Date: Feb 2015
Location: Bluffton, South Carolina
Trailer: 2014 Escape 5.0TA
Posts: 135
Thanks Carl,
I'll do as you suggest and let you know.
We're in Ft. Myers another two weeks working with Habitat.
D&R_SC is offline   Reply With Quote
Old 03-18-2017, 06:46 PM   #6
Site Team
 
padlin's Avatar
 
Join Date: Sep 2009
Location: Southwick, Massachusetts
Trailer: 5.0 TA #6, 2012 F150 EB
Posts: 5,861
Quote:
Originally Posted by D&R_MA View Post
Checked those two fuses and they appear to be ok.
Thanks Alf
Did you check them with a meter or just eyeball them? if the later, try swapping them around, can't always see a blown fuse.
__________________
Happy Motoring
Bob
padlin is offline   Reply With Quote
Old 03-18-2017, 07:54 PM   #7
Senior Member
 
Join Date: Feb 2015
Location: Bluffton, South Carolina
Trailer: 2014 Escape 5.0TA
Posts: 135
Quote:
Originally Posted by padlin View Post
Did you check them with a meter or just eyeball them? if the later, try swapping them around, can't always see a blown fuse.
Will try switching and let you know.
Thanks
D&R_SC is offline   Reply With Quote
Old 03-19-2017, 04:26 PM   #8
Senior Member
 
Join Date: Feb 2015
Location: Bluffton, South Carolina
Trailer: 2014 Escape 5.0TA
Posts: 135
Switched fuses and now both work.

Quote:
Originally Posted by D&R_MA View Post
Will try switching and let you know.
Thanks
Took Padlin's advice and switched the original two fuses. Now both Jack's work. Mine is not to reason why, ..........

Thanks to all who offered suggestions,

David
D&R_SC is offline   Reply With Quote
Old 03-19-2017, 04:43 PM   #9
Senior Member
 
Join Date: Mar 2013
Location: North of Hertel, Wisconsin
Trailer: TBD
Posts: 2,147
Fuse holder corrode and with only 12 volts it doesn't take much corrosion to cause a problem .Sometimes just taking the fuse in and out will clean it up enough to make contact. 120 VAC is not so sensitive .
steve dunham is offline   Reply With Quote
Old 03-19-2017, 04:44 PM   #10
Senior Member
 
escape artist's Avatar
 
Join Date: Oct 2008
Location: St. Thomas not BVI., Ontario
Trailer: 2014 Escape 5.0TA / 2016 Ram Eco Diesel 4X4
Posts: 6,230
Quote:
Originally Posted by D&R_MA View Post
Checked those two fuses and they appear to be ok.
Thanks Alf
Hi: D&R_MA... Seems like you lucked out... this time. Corrosion could have been the culprit. We have a TV remote at home that quits working now& then. I swap the AA's around and it's ok again.
I always try the cheap fix first... there's lots of time for the $pendy one later. Alf
escape artist N.S. of Lake Erie
__________________
Quote Bugs Bunny..."Don't take life too seriously, none of us get out of it ALIVE"!!!
'16 Ram Eco D. 4X4 Laramie Longhorn CC & '14 Escape 5.0TA
St.Thomas (Not the Virgin Islands) Ontario
escape artist is offline   Reply With Quote
Old 03-19-2017, 04:53 PM   #11
Senior Member
 
Join Date: Feb 2015
Location: Bluffton, South Carolina
Trailer: 2014 Escape 5.0TA
Posts: 135
Quote:
Originally Posted by escape artist View Post
Hi: D&R_MA... Seems like you lucked out... this time. Corrosion could have been the culprit. We have a TV remote at home that quits working now& then. I swap the AA's around and it's ok again.
I always try the cheap fix first... there's lots of time for the $pendy one later. Alf
escape artist N.S. of Lake Erie
Often better to be lucky than good.
D&R_SC is offline   Reply With Quote
Old 03-19-2017, 05:42 PM   #12
Senior Member
 
escape artist's Avatar
 
Join Date: Oct 2008
Location: St. Thomas not BVI., Ontario
Trailer: 2014 Escape 5.0TA / 2016 Ram Eco Diesel 4X4
Posts: 6,230
Quote:
Originally Posted by D&R_MA View Post
Often better to be lucky than good.
Hi: D&R_MA... Memories of Scamp camp & our side trip!!! Alf
escape artist N.S. of Lake Erie
Attached Images
File Type: jpg 20170211_140142.jpg (348.4 KB, 7 views)
File Type: jpg 20170211_140542.jpg (241.8 KB, 9 views)
File Type: jpg 20170215_170510.jpg (402.8 KB, 9 views)
__________________

__________________
Quote Bugs Bunny..."Don't take life too seriously, none of us get out of it ALIVE"!!!
'16 Ram Eco D. 4X4 Laramie Longhorn CC & '14 Escape 5.0TA
St.Thomas (Not the Virgin Islands) Ontario
escape artist is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Escape Trailer Industries or any of its affiliates. This is an independent, unofficial site.


All times are GMT -5. The time now is 03:40 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2012 Social Knowledge, LLC All Rights Reserved.
×