Did I screw up my Fridge ? - Escape Trailer Owners Community

Go Back   Escape Trailer Owners Community > Escape Tech > Problem Solving | Owners helping each other
Thread Tools Display Modes
Old 06-20-2013, 11:51 PM   #1
Junior Member
Join Date: Mar 2013
Location: New Westminster, British Columbia
Trailer: 2004 17' "B" And a 1971 Boler
Posts: 6
Did I screw up my Fridge ?

So I hooked up the trailer last night, in preparation to leave this am and I pulled the rig around in front of my house. I hooked up the 120v to keep the fridge "pre-chilled" and left her for the night. Oh yes, the whole unit sat on a 6%grade. When I went to load up this am it was not cold, I ran it on 12v for the 5 hrs that i was on the road and still not cold..... did I wreck it ? or is this a temporary thing where I just have to be patient ? HELP PLEASE

Boler owner is offline   Reply With Quote
Old 06-21-2013, 06:07 AM   #2
Site Team
Donna D.'s Avatar
Join Date: Nov 2008
Location: Portland, Oregon
Trailer: 2014 Escape 5.0 TA
Posts: 5,423
My frig wouldn't cool down at that angle either. I don't think you've harmed it. I know more knowledgable folks will be around shortly to offer more opinions.
Donna D. is online now   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by

All times are GMT -5. The time now is 05:15 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Copyright 2012 Social Knowledge, LLC All Rights Reserved.