Domestic RM2510 Puzzlement - Escape Trailer Owners Community

Go Back   Escape Trailer Owners Community > Escape Tech > Problem Solving | Owners helping each other
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 08-16-2019, 04:19 PM   #1
Senior Member
 
Join Date: Jun 2009
Location: Terrace, British Columbia
Trailer: 2012 Escape 19
Posts: 348
Dometic RM2510 Puzzlement

We've been having an issue with our RM2510 fridge. It runs fine on gas but not on 120vac. I brought it home from storage to troubleshoot it today. It will cool the freezer down to -6C but the refrigerator part remains at +18C which is the ambient temp in the trailer. I can't figure out why this is happening. The temp control is set at '3'. Any suggestions?

Doug
__________________

NuthatchBC is offline   Reply With Quote
Old 08-20-2019, 01:32 AM   #2
Senior Member
 
Join Date: Sep 2016
Location: Redwood City, California
Trailer: 2017 Escape 19
Posts: 190
I'd start with cranking it to '5' and waiting longer. If that fails, maybe make sure it's actually getting 120V even when it's running rather than some sort of voltage drop on the way. It sounds like the boiler just isn't getting hot enough.
__________________

Defenestrator is offline   Reply With Quote
Old 08-20-2019, 08:30 AM   #3
Senior Member
 
Vermilye's Avatar
 
Join Date: Feb 2010
Location: Oswego, New York
Trailer: 2017 Escape 21, 2018 Ford F150
Posts: 3,448
I hope it is because the plug fell out, or the 120V heater element is burned out, but in my case it was the thermostat, three times. You must pull the refrigerator to replace the thermostat.

I pulled apart one of the bad thermostats, and there is a switch operated by a cam driven by the diaphragm. The linkage was jammed so that the switch never closed.
__________________
Jon Vermilye My Travel Blog
Travel and Photo Web Page ... My Collection of RV Blogs 2018 F150 3.5EB, 2017 21
Vermilye is offline   Reply With Quote
Old 08-20-2019, 08:38 AM   #4
Senior Member
 
Jim Bennett's Avatar
 
Join Date: Oct 2008
Location: Calgary, Alberta
Trailer: 2017 Escape 5.0 TA
Posts: 14,159
I too had to replace the thermostat in the fridge in my 19. I bit of a pain, but not too tough.
__________________
2017 Escape 5.0 TA
2015 Ford F150 Lariat 3.5L EcoBoost
2009 Escape 19 (previous)
“Most folks are about as happy as they make up their minds to be.” — Abraham Lincoln
Jim Bennett is offline   Reply With Quote
Old 08-20-2019, 08:54 AM   #5
Senior Member
 
escape artist's Avatar
 
Join Date: Oct 2008
Location: St. Thomas not BVI., Ontario
Trailer: 2014 Escape 5.0TA / 2016 Ram Eco Diesel 4X4
Posts: 6,217
Hi: All... On the "Domestic" front, we both have thermostatic issues. Some call 'em "Power surges". Alf
escape artist N.S. of Lake Erie
__________________
Quote Bugs Bunny..."Don't take life too seriously, none of us get out of it ALIVE"!!!
'16 Ram Eco D. 4X4 Laramie Longhorn CC & '14 Escape 5.0TA
St.Thomas (Not the Virgin Islands) Ontario
escape artist is online now   Reply With Quote
Old 08-20-2019, 11:40 AM   #6
Senior Member
 
Join Date: Jun 2009
Location: Terrace, British Columbia
Trailer: 2012 Escape 19
Posts: 348
Well, the "Domestic" typo was done by the damn autocorrect on my cell. Should have reviewed prior to posting.

Anyway, I did put the temp control on 6 and it seems to be working now. The fridge temp was 6C and the freezer -21C after about three hours. Prior to doing that, I vigorously rotated the control hoping to clean the contacts if that could have been the problem. Maybe it was, I don't know. If I have an intermittent, I'm probably 'hooped' because those are almost impossible to sneak up on. I'll 'stand by' for now and see how it performs. Thanks for all of the input.

Doug
__________________
We're still have'n fun...
NuthatchBC is offline   Reply With Quote
Old 08-20-2019, 12:12 PM   #7
Senior Member
 
escape artist's Avatar
 
Join Date: Oct 2008
Location: St. Thomas not BVI., Ontario
Trailer: 2014 Escape 5.0TA / 2016 Ram Eco Diesel 4X4
Posts: 6,217
Quote:
Originally Posted by NuthatchBC View Post
Well, the "Domestic" typo was done by the damn autocorrect on my cell. Should have reviewed prior to posting.

Anyway, I did put the temp control on 6 and it seems to be working now. The fridge temp was 6C and the freezer -21C after about three hours. Prior to doing that, I vigorously rotated the control hoping to clean the contacts if that could have been the problem. Maybe it was, I don't know. If I have an intermittent, I'm probably 'hooped' because those are almost impossible to sneak up on. I'll 'stand by' for now and see how it performs. Thanks for all of the input.

Doug
Hi: NuthatchBC... I hate autocorrect. I really don't need it cause I'm married. Don't need google either!!! I used to tell my kids "Nothing is lost till your mother can't find it". Alf
escape artist N.S. of Lake Erie
__________________
Quote Bugs Bunny..."Don't take life too seriously, none of us get out of it ALIVE"!!!
'16 Ram Eco D. 4X4 Laramie Longhorn CC & '14 Escape 5.0TA
St.Thomas (Not the Virgin Islands) Ontario
escape artist is online now   Reply With Quote
Old 08-20-2019, 04:14 PM   #8
Senior Member
 
Vermilye's Avatar
 
Join Date: Feb 2010
Location: Oswego, New York
Trailer: 2017 Escape 21, 2018 Ford F150
Posts: 3,448
Quote:
Originally Posted by NuthatchBC View Post
Well, the "Domestic" typo was done by the damn autocorrect on my cell. Should have reviewed prior to posting.

Anyway, I did put the temp control on 6 and it seems to be working now. The fridge temp was 6C and the freezer -21C after about three hours. Prior to doing that, I vigorously rotated the control hoping to clean the contacts if that could have been the problem. Maybe it was, I don't know. If I have an intermittent, I'm probably 'hooped' because those are almost impossible to sneak up on. I'll 'stand by' for now and see how it performs. Thanks for all of the input.

Doug
Glad that was all there was to the problem!
__________________
Jon Vermilye My Travel Blog
Travel and Photo Web Page ... My Collection of RV Blogs 2018 F150 3.5EB, 2017 21
Vermilye is offline   Reply With Quote
Old 09-27-2019, 09:43 PM   #9
Senior Member
 
currinh's Avatar
 
Join Date: Jun 2014
Location: Box Elder, South Dakota
Trailer: Escape 19' 2011
Posts: 346
Doug:

We've found it takes a day or two for the temp to cool down after the 'fridge gets too hot. Recovery in 3 hours we'd consider excellent.

Quote:
Originally Posted by NuthatchBC View Post
Anyway, I did put the temp control on 6 and it seems to be working now. The fridge temp was 6C and the freezer -21C after about three hours.
Doug
__________________

__________________
Hugh Currin
2011 Escape 19
2018 RAM 2500 Diesel
currinh is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Escape Trailer Industries or any of its affiliates. This is an independent, unofficial site.


All times are GMT -5. The time now is 10:08 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2012 Social Knowledge, LLC All Rights Reserved.
×