Dometic RM2510 cooling issue (on electric only) - Page 2 - Escape Trailer Owners Community

Go Back   Escape Trailer Owners Community > Escape Tech > Problem Solving | Owners helping each other
Thread Tools Display Modes
Old 07-11-2015, 03:08 AM   #11
Senior Member
Join Date: Apr 2014
Location: Olympia wa, Washington
Trailer: 17ft B Escape "lark"
Posts: 615
It lit up tonight pretty sure by tomorrow it will be on -odd

Fox hunt is offline   Reply With Quote
Old 07-11-2015, 04:22 AM   #12
Site Team
cpaharley2008's Avatar
Join Date: Jun 2010
Location: York, Pennsylvania
Trailer: 2016 2ndGen Escape 19' PRAIRIE SCHOONER pulled by 2014 Ram Hemi/8sp
Posts: 10,282

never in doubt, often wrong
cpaharley2008 is offline   Reply With Quote
Old 07-11-2015, 01:30 PM   #13
Senior Member
rbryan4's Avatar
Join Date: Jun 2014
Location: San Antonio, Texas
Trailer: 2015 19 "Past Tents", 2015 F150 Ecoboost
Posts: 5,346
Originally Posted by tractors1 View Post
Have you checked that all electrical connections are tight - they can loosed up from vibration. Otherwise I'd suspect the control board.
Probably. If the control board doesn't sense sufficient voltage, the fridge won't power up.

"You can't buy happiness, but you can buy an RV. And that is pretty close."
rbryan4 is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by

All times are GMT -5. The time now is 09:11 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Copyright 2012 Social Knowledge, LLC All Rights Reserved.