FullTiming-propane not happy with cold weather - Page 9 - Escape Trailer Owners Community

Go Back   Escape Trailer Owners Community > Escape Tech > Problem Solving | Owners helping each other
Thread Tools Display Modes
Old 12-08-2015, 09:44 PM   #81
Join Date: Jan 2013
Location: Eagle, Colorado
Trailer: 2013 Escape 19
Posts: 37

Well, the replacement regulator is working just fine. And because the fates like to mess with us, a few days after replacing the regulator, the typical Seattle rains came back and temps began to rise.

With the 15 day forecast showing lots of rain and barely ever getting near freezing temps, I am feeling good about my full-timing again. Warm and dry is so nice.

Thanks to everyone for the advice and the information. Knowing this forum was here as a resource was part of what gave me the confidence to start this adventure. 4 months done, 6 weeks left.


kmart is offline   Reply With Quote
Old 12-09-2015, 10:34 AM   #82
Senior Member
Greg A's Avatar
Join Date: Oct 2013
Location: Phoenix, Arizona
Trailer: 2015 Escape 19 "Seventy Degrees"
Posts: 1,304
Hi Kelly! Glad to hear you got it resolved. Wow, 6 weeks left in the ol KOA.
Be safe on your travels when you head home and hope to meet ya'll out on the road again.

Greg A is online now   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by

All times are GMT -5. The time now is 04:55 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Copyright 2012 Social Knowledge, LLC All Rights Reserved.