Furnace Issue - Escape Trailer Owners Community

Go Back   Escape Trailer Owners Community > Escape Tech > Problem Solving | Owners helping each other
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 03-27-2014, 07:59 PM   #1
Senior Member
 
Join Date: Apr 2013
Location: Newnan, Georgia
Trailer: 2013 Escape 5.0 "Day Break"
Posts: 140
Furnace Issue

Hey all,
Down here in Florida and wanted to warm up some last night. Turned furnace on and it worked! Then it cycled off and that's it. Went through the range of troubleshooting and all looked good... Even "rebooted" the camper... Nothing. I removed the cover from the furnace and noticed a red light flashing on the printed circuit card. Any ideas? I tried to call ETI tonight but I missed them, so will call in the morning.

Just thought I would check with you seasoned owners. This is trip 6 for me, and I have used it 2 times prior with no events.

Did my heater give up it's ghost?

Todd

Thanks for any help in advance.
__________________

itoddday is offline   Reply With Quote
Old 03-27-2014, 08:09 PM   #2
Senior Member
 
gbaglo's Avatar
 
Join Date: Oct 2008
Location: North Vancouver, British Columbia
Trailer: 2009 Escape 17B - "Toad". '08 Toyota RAV4 V6
Posts: 10,735
I think that's where you look up Authorized Service Centers and have it fixed under warranty. I wouldn't mess with it and maybe lose my warranty.
__________________

__________________
2009 Escape 17B "Toad"
2008 Toyota RAV4 V6 Sport
North Vancouver, British Columbia

What happens to the hole when the cheese is gone?
- Bertolt Brecht
gbaglo is offline   Reply With Quote
Old 03-27-2014, 08:21 PM   #3
Site Team
 
cpaharley2008's Avatar
 
Join Date: Jun 2010
Location: York, Pennsylvania
Trailer: 2016 2ndGen Escape 19' PRAIRIE SCHOONER pulled by 2014 Ram Hemi/8sp
Posts: 13,675
Here are some instructions, there is an "on/off" switch I believe
http://www.fourwheelcampers.com/atwo...structions.pdf
__________________
Jim
The two most important days in your life are the day you were born and the day you find out why………..Mark Twain
cpaharley2008 is offline   Reply With Quote
Old 03-27-2014, 09:00 PM   #4
Senior Member
 
Join Date: Apr 2013
Location: Newnan, Georgia
Trailer: 2013 Escape 5.0 "Day Break"
Posts: 140
Jim,

Thank you! Your brilliant! Found the reset switch, did the reset and I have heat! If it were a snake, it would have bit me!

Todd
itoddday is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






» Virginia Campgrounds

Reviews provided by



All times are GMT -5. The time now is 06:10 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 Social Knowledge, LLC All Rights Reserved.