GoPower solar controller never goes above 85% - Escape Trailer Owners Community

Go Back   Escape Trailer Owners Community > Escape Tech > Problem Solving | Owners helping each other
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 05-31-2014, 12:43 PM   #1
Senior Member
 
7th Heaven's Avatar
 
Join Date: Feb 2014
Location: palo alto, California
Trailer: 2013 Escape 21 #7
Posts: 187
GoPower solar controller never goes above 85%

So I'm a little perplexed after we returned from out last weekend trip the go power controller never goes above 85%

What do I need to check?

Battery fluid is good.
Volts are good on the controller and via multimeter (13.8)
Solar is sending power to the battery
__________________

__________________
7-7-7 Our Marriage
2008 A Daughter 2011 A Son Dec-2014 A Daughter
2013 Escape 21 2014 Sequoia
7th Heaven is offline   Reply With Quote
Old 05-31-2014, 01:32 PM   #2
Senior Member
 
Vermilye's Avatar
 
Join Date: Feb 2010
Location: Oswego, New York
Trailer: 2016 Tacoma Off Road, 2017 21
Posts: 2,279
Is it possible that you have the refrigerator on 12V? That would cause the problem...
__________________

__________________
Jon Vermilye My Travel Blog
Travel and Photo Web Page ... My Collection of RV Blogs 2016 Tacoma, 2017 21
Vermilye is offline   Reply With Quote
Old 05-31-2014, 03:00 PM   #3
Senior Member
 
7th Heaven's Avatar
 
Join Date: Feb 2014
Location: palo alto, California
Trailer: 2013 Escape 21 #7
Posts: 187
Hi Jon,

At the moment everything is turned off. On this past trip refrigerator was on propane the whole time. On our very first trip however I had started using batter but switched to propane half way through the weekend.

Thoughts?
__________________
7-7-7 Our Marriage
2008 A Daughter 2011 A Son Dec-2014 A Daughter
2013 Escape 21 2014 Sequoia
7th Heaven is offline   Reply With Quote
Old 05-31-2014, 03:34 PM   #4
Senior Member
 
Join Date: Mar 2013
Location: n/a, Texas
Trailer: Escape
Posts: 220
Do you have the controller set to the right type of battery?
Viajante is offline   Reply With Quote
Old 05-31-2014, 06:20 PM   #5
Senior Member
 
Join Date: Aug 2012
Location: N/A, Indiana
Trailer: Escape
Posts: 931
Although there are a lot of variables using solar to charge the batteries, I have found the maximum power boost to be effective.
http://gpelectric.com/files/gpelectr...ler2-FINAL.pdf
__________________
"Never argue with an idiot. They only bring you down to their level and beat you with experience." George Carlin
Jubal is offline   Reply With Quote
Old 05-31-2014, 06:38 PM   #6
Senior Member
 
7th Heaven's Avatar
 
Join Date: Feb 2014
Location: palo alto, California
Trailer: 2013 Escape 21 #7
Posts: 187
I checked that it was set to flooded
__________________
7-7-7 Our Marriage
2008 A Daughter 2011 A Son Dec-2014 A Daughter
2013 Escape 21 2014 Sequoia
7th Heaven is offline   Reply With Quote
Old 05-31-2014, 07:59 PM   #7
Senior Member
 
Join Date: Mar 2013
Location: n/a, Texas
Trailer: Escape
Posts: 220
As far as I know the % readout doesn't tell you how full the battery is in terms of amp hours. It just measures voltage. As soon as the voltage rises above 12.7 the readout says 100%, even if the battery is a long way from fully charged. As long as you confirmed that the battery is getting up to 13.6 or so volts during charging, and are seeing that the panel is putting out amperage, you don't really have a problem, just a bothersome display glitch. You might try disconnecting the controller from the battery, then reconnect it and see if it resets itself.
Viajante is offline   Reply With Quote
Old 06-01-2014, 02:57 PM   #8
Senior Member
 
7th Heaven's Avatar
 
Join Date: Feb 2014
Location: palo alto, California
Trailer: 2013 Escape 21 #7
Posts: 187
I tried disconnecting power this morning. No such luck..

For the last few hours I've turned on the fans and refer to put a load on the system

I'm generating 4+ on the panel, volts are still above 13 but the display is still at 85% ... I'm going to get the % to drop and then watch the recharge.

I may need to call go power on this one...
__________________
7-7-7 Our Marriage
2008 A Daughter 2011 A Son Dec-2014 A Daughter
2013 Escape 21 2014 Sequoia
7th Heaven is offline   Reply With Quote
Old 06-27-2014, 11:44 PM   #9
Senior Member
 
7th Heaven's Avatar
 
Join Date: Feb 2014
Location: palo alto, California
Trailer: 2013 Escape 21 #7
Posts: 187
Problem Fixed....

Turns out the Solar Controller was bad. a call to GoPower resolved by sending a replacement unit.
__________________
7-7-7 Our Marriage
2008 A Daughter 2011 A Son Dec-2014 A Daughter
2013 Escape 21 2014 Sequoia
7th Heaven is offline   Reply With Quote
Old 06-28-2014, 07:14 PM   #10
Senior Member
 
Join Date: Mar 2013
Location: n/a, Texas
Trailer: Escape
Posts: 220
Thanks for the update. Glad to know the problem is fixed.
__________________

Viajante is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






» Virginia Campgrounds

Reviews provided by



All times are GMT -5. The time now is 07:38 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 Social Knowledge, LLC All Rights Reserved.