Hot water tank now not working on electric or propane - Page 2 - Escape Trailer Owners Community

Go Back   Escape Trailer Owners Community > Escape Tech > Problem Solving | Owners helping each other
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 04-20-2014, 11:30 PM   #11
Senior Member
 
Join Date: Feb 2010
Location: ?, Arizona
Trailer: ?
Posts: 736
Quote:
Originally Posted by daveandsandyclink View Post
I am not completely sure that's correct Doug but I believe that my 2003 Suburban gas/electric hot water heater did not work from an experience when I mistakenly burned out the electric element. It was wired in series with the heater's propane valve. It's only a suggestion to consider and only takes a few minutes to confirm.
I would be VERY surprised. The propane valve is 12V DC. The electric heating element is 120V AC. See figure 6 in http://bryantrv.com/docs2/docs/subsw.pdf
The thermostat and limit switches are NOT shared due to the differing voltages and currents involved (see page 18 of the same document.)
__________________

jamman is offline   Reply With Quote
Old 04-21-2014, 08:58 AM   #12
Senior Member
 
Join Date: Dec 2011
Location: _, Texas
Trailer: Escape 5.0 SA
Posts: 545
Your right Doug...it's got to be something common to the entire system. Thanks for the electronic document. I haven't seen him reply. Maybe it's fixed. I nothing else have it looked at by a RV technician.
__________________

daveandsandyclink is offline   Reply With Quote
Old 04-21-2014, 11:37 AM   #13
Senior Member
 
Chapitre's Avatar
 
Join Date: May 2012
Location: Halifax, Nova Scotia
Trailer: 2014 5TA/ *012 17B (previous)
Posts: 396
Update:
Had the RV Tech come by and look at the hot water tank-
One of the first things he did was check the "circuit board" he said sometimes they get dirty he used an eraser to buff up the four little electronic panels - voila- the propane worked after that.
One problem that he did see was that the circuit board was directly on the floor beside the hot water tank, where it appeared to be affected a bit by water ( maybe dripping during winterization etc.) he said they are usually up off the floor - they actually come with a piece of foam on the bottom - ours was just screwed directly on the floor - probably not the best place.
The electrical he checked all the electrical ohms/ amps etc. We asked him about the reset buttons- he said they really are not a reset, they don't do much. The right side( where the rest buttons are) is the 12v and the left side is the 120v. He said because we had hot water on electric then it went to Luke warm, it was likely the thermostat, which it was- replaced the and now the electric is working as well.
I'm not 100% sure but it seems like the main thing that propane and electric have in common is the " circuit" board.
Hope that helps a bit.
We're just glad it's fixed, the fact that they both stopped working one after the other was just a fluke I guess.
__________________
Min D
Chapi II
--------------------
'Have No Regrets'
Chapitre is offline   Reply With Quote
Old 04-21-2014, 12:00 PM   #14
Senior Member
 
Join Date: Feb 2010
Location: ?, Arizona
Trailer: ?
Posts: 736
Glad to hear it is doubly fixed. The circuit board is only for the gas - it controls the igniter and gas valve. See the diagrams in the manual I referenced. I think you had 2 unrelated failures - 110V thermostat and dirty/wet circuit board contacts.

I would suggest avoiding casinos until you get a string of good luck.
jamman is offline   Reply With Quote
Old 04-21-2014, 12:02 PM   #15
Senior Member
 
Chapitre's Avatar
 
Join Date: May 2012
Location: Halifax, Nova Scotia
Trailer: 2014 5TA/ *012 17B (previous)
Posts: 396
Sounds right,
Thanks
__________________
Min D
Chapi II
--------------------
'Have No Regrets'
Chapitre is offline   Reply With Quote
Old 04-21-2014, 12:30 PM   #16
Senior Member
 
gbaglo's Avatar
 
Join Date: Oct 2008
Location: North Vancouver, British Columbia
Trailer: 2009 Escape 17B - "Toad". '08 Toyota RAV4 V6
Posts: 10,741
Any idea what he meant by saying "they're not really reset buttons".
When my buddy had a problem with his 19 water heater, Reace told him to press the reset. He did and it worked.
__________________
2009 Escape 17B "Toad"
2008 Toyota RAV4 V6 Sport
North Vancouver, British Columbia

What happens to the hole when the cheese is gone?
- Bertolt Brecht
gbaglo is offline   Reply With Quote
Old 04-21-2014, 12:39 PM   #17
Senior Member
 
Join Date: Feb 2010
Location: ?, Arizona
Trailer: ?
Posts: 736
Quote:
Originally Posted by gbaglo View Post
Any idea what he meant by saying "they're not really reset buttons".
When my buddy had a problem with his 19 water heater, Reace told him to press the reset. He did and it worked.
They should really be called "temperature circuit breakers" (aka high-limit switches) - they trip if the water gets too hot. If things are working right they should never trip. If they do need to be reset it is usually because the thermostat failed or is not touching the tank. And they will need to be reset until the thermostat problem is fixed.
jamman is offline   Reply With Quote
Old 04-21-2014, 04:24 PM   #18
Senior Member
 
santacruzer's Avatar
 
Join Date: May 2012
Location: Santa Cruz, California
Trailer: 2014 Escape 19
Posts: 686
My water pump went out last summer, leaking into the compartment. In replacing it I noticed the circuit board on the floor also, although at the time I didn't realize it was a circuit board. Fortunately, none of the water that leaked got into it, but I made it a point to raise it up off the floor anyway. Reace told me later that that fix has been done.
__________________

__________________
2009 Tacoma Crew Cab, TRD 4WD
2007 Tundra Double Cab TRD 4WD
2014 Escape 19
2007 Norwegian Elkhound "Baxter"
santacruzer is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






» Virginia Campgrounds

Reviews provided by



All times are GMT -5. The time now is 02:24 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 Social Knowledge, LLC All Rights Reserved.