Hot water tank problems - Escape Trailer Owners Community

Go Back   Escape Trailer Owners Community > Escape Tech > Problem Solving | Owners helping each other
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 04-16-2014, 07:58 PM   #1
Senior Member
 
barry's Avatar
 
Join Date: Jun 2010
Location: Mission, British Columbia
Trailer: 2012 Escape "Classic" 5.0
Posts: 350
Hot water tank problems

I'm having problems with my hot water tank.

One evening last November, at the end of a trip, our hot water tank was failing to ignite. It would start for a few seconds and then go out, then start for a few more seconds and go out again. I turned it off and then tried it the next morning and it worked without problem and I put it down to the fact that it was a windy night.

We just got back from a trip on Sunday and the hot water heater had worked without any problems until the eighth evening when the aroma of "rotten eggs" filled the trailer. I noticed that red light for the hot water tank was on and was staying on without the heater igniting. I turned off the switch and left it for about 30 mins. and then turned it on again and it ignited but went out after a few seconds as had happened in November; so I left it off for the rest of the evening. The next morning I tried it again, the light would come on and then we would hear a click and the light would go off but the heater would not ignite; it kept on doing this multiple times but I would get no ignition so I left it off for the remainder of the trip. Both the propane furnace and the gas hob were working so I had plenty of propane. I even switched over to a new full propane bottle with no success.

The trailer is just two years old this month. I sent an e-mail to Reace on the weekend and have yet to hear back (I guess he is really busy) so I thought I would throw it out to the forum members for ideas on a fix.

Thanks in advance.

Barry
__________________

__________________
Photography website: https://bjustice.zenfolio.com/

2012 Escape "Classic" 5.0 / 2017 F150, 2.7 EcoBoost 4X4 Supercab
Former trailers: 2005 Escape 17B / 1972 Boler 13'
barry is offline   Reply With Quote
Old 04-16-2014, 08:22 PM   #2
Senior Member
 
gbaglo's Avatar
 
Join Date: Oct 2008
Location: North Vancouver, British Columbia
Trailer: 2009 Escape 17B - "Toad". '08 Toyota RAV4 V6
Posts: 10,715
Go here: Water heater issue

starting with post #11 and you may find a solution.
__________________

__________________
2009 Escape 17B "Toad"
2008 Toyota RAV4 V6 Sport
North Vancouver, British Columbia

What happens to the hole when the cheese is gone?
- Bertolt Brecht
gbaglo is offline   Reply With Quote
Old 04-16-2014, 09:26 PM   #3
Senior Member
 
barry's Avatar
 
Join Date: Jun 2010
Location: Mission, British Columbia
Trailer: 2012 Escape "Classic" 5.0
Posts: 350
Thanks Glenn.

I just found out that you have to be really gentle with the prongs ...... they break really easily!

Barry
__________________
Photography website: https://bjustice.zenfolio.com/

2012 Escape "Classic" 5.0 / 2017 F150, 2.7 EcoBoost 4X4 Supercab
Former trailers: 2005 Escape 17B / 1972 Boler 13'
barry is offline   Reply With Quote
Old 04-16-2014, 09:28 PM   #4
Senior Member
 
gbaglo's Avatar
 
Join Date: Oct 2008
Location: North Vancouver, British Columbia
Trailer: 2009 Escape 17B - "Toad". '08 Toyota RAV4 V6
Posts: 10,715
C'mon, don't leave us in suspenders.
__________________
2009 Escape 17B "Toad"
2008 Toyota RAV4 V6 Sport
North Vancouver, British Columbia

What happens to the hole when the cheese is gone?
- Bertolt Brecht
gbaglo is offline   Reply With Quote
Old 04-16-2014, 09:34 PM   #5
Senior Member
 
barry's Avatar
 
Join Date: Jun 2010
Location: Mission, British Columbia
Trailer: 2012 Escape "Classic" 5.0
Posts: 350
Put it this way; I'm heading out to Fraserway RV in the morning. Reace just got back to me so I'll get it fixed one way or the other.

Barry
__________________
Photography website: https://bjustice.zenfolio.com/

2012 Escape "Classic" 5.0 / 2017 F150, 2.7 EcoBoost 4X4 Supercab
Former trailers: 2005 Escape 17B / 1972 Boler 13'
barry is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






» Virginia Campgrounds

Reviews provided by



All times are GMT -5. The time now is 04:16 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 Social Knowledge, LLC All Rights Reserved.