LED fail - Escape Trailer Owners Community

Go Back   Escape Trailer Owners Community > Escape Tech > Problem Solving | Owners helping each other
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 03-03-2015, 04:30 PM   #1
Senior Member
 
Bruce Wray's Avatar
 
Join Date: Jan 2009
Location: Pollock Pines, California
Trailer: 2009 Escape 19
Posts: 452
LED fail

Several years ago I bought a fridge light kit from a lady on the Casita forum who makes them. Now some of the individual LEDs in the strip, like every other one, are out. Any ideas as to what's going on, and possible remedies, including replacing the strip segment?

Bruce
__________________

Bruce Wray is offline   Reply With Quote
Old 03-03-2015, 05:59 PM   #2
Senior Member
 
Jim Bennett's Avatar
 
Join Date: Oct 2008
Location: Calgary, Alberta
Trailer: 2017 Escape 5.0 TA
Posts: 11,932
Is it one of the adhesive strips, Bruce. If so it is readily available. Lee Valley sells it by the foot, I know.
__________________
2017 Escape 5.0 TA
2015 Ford F150 Lariat 3.5L EcoBoost
2009 Escape 19 (previous)
“Most folks are about as happy as they make up their minds to be.” — Abraham Lincoln
Jim Bennett is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






» Virginia Campgrounds

Reviews provided by



All times are GMT -5. The time now is 11:19 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 Social Knowledge, LLC All Rights Reserved.