Maxxfan not working - Page 2 - Escape Trailer Owners Community

Go Back   Escape Trailer Owners Community > Escape Tech > Problem Solving | Owners helping each other
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 11-07-2017, 04:11 PM   #11
Senior Member
 
float5's Avatar
 
Join Date: Nov 2010
Location: Denison, Texas
Trailer: 2015 21'; 2011 19' sold; 4Runner; ph ninezero3 327-27ninefour
Posts: 4,831
Quote:
Originally Posted by LJY View Post
Attention Admins

FYI, there seems to be an issue posting replies? it's happened with dragoon's reply on this thread and wetzk's reply in another thread.
I get emails for both, but neither posts are showing in the web thread
Go to the bottom of the page where it says, "Contact Us", and you can write the admins there.
__________________

__________________
Cathy. Floating Cloud
"Live in the sunshine, swim the sea, drink the wild air.... "
Emerson
float5 is offline   Reply With Quote
Old 11-07-2017, 08:50 PM   #12
Senior Member
 
Devil Dog's Avatar
 
Join Date: Feb 2012
Location: Steveston B.C., British Columbia
Trailer: 2012- 17'B.... 2016 Tacoma SR5 TRD
Posts: 448
To replace the electronics you have to buy the hole fan assembly . About 325.00 ca.
of course you'll have spare parts.
In 2015 the fan craped in trailer out at 38c. Douglas lake area , went to Kamloops for parts at 42c and the ac in the truck packed it in as the wife was shopping for what seemed for hours .
Got the fan in the trailer working ok. the truck was 2 weeks away . almost died. ...
__________________

__________________
I've almost been everywhere man.
Almost been everywhere.....
Devil Dog is offline   Reply With Quote
Old 11-08-2017, 12:21 PM   #13
Senior Member
 
Join Date: Aug 2013
Location: Naples, Florida
Trailer: New 21 Escape (not classic)10/16 Sold Lil Snoozy 7/16
Posts: 294
maxxfan

My maxxfan seems to be making a clicking sound and as I ramp up speed it gets louder ? I wonder if the bearings in the motor are going ? We are still under warranty . how hard is it to take motor off the fan part and take it to a maxxfan service center ?
jennykatz is offline   Reply With Quote
Old 11-13-2017, 10:06 PM   #14
LJY
Senior Member
 
Join Date: Mar 2016
Location: Nor, California
Trailer: 2017 Escape
Posts: 200
Pat,
I just got the new circuit board. Didn't come with any instructions.. any tips?
LJY is offline   Reply With Quote
Old 11-13-2017, 10:34 PM   #15
Junior Member
 
Join Date: Oct 2013
Location: Comox, British Columbia
Trailer: Escape 17B, 2016
Posts: 10
Hi, remove inside panel, 5 screws, one on each corner and 1 on manual handle. The entire panel will drop down. You will see the circuit card. Drop the circuit card down and remove the connecting plugs. You will have to cut the positive and negative connection to attach new card. Re-install making sure your wiring is tucked up inside the panel area. Tools I used wire strippers, plastic zip ties, wire connectors X2, electrical tape, Philips screwdriver. Pretty simple job , take your time. Also forgot to mention take screen off first, Pat. I tried to insert images but no luck.
dragoon is offline   Reply With Quote
Old 11-14-2017, 11:50 PM   #16
LJY
Senior Member
 
Join Date: Mar 2016
Location: Nor, California
Trailer: 2017 Escape
Posts: 200
Quote:
Originally Posted by dragoon View Post
Hi, remove inside panel, 5 screws, one on each corner and 1 on manual handle. The entire panel will drop down. You will see the circuit card. Drop the circuit card down and remove the connecting plugs. You will have to cut the positive and negative connection to attach new card. Re-install making sure your wiring is tucked up inside the panel area. Tools I used wire strippers, plastic zip ties, wire connectors X2, electrical tape, Philips screwdriver. Pretty simple job , take your time. Also forgot to mention take screen off first, Pat. I tried to insert images but no luck.
Thank you, I bought the parts and will try tomorrow.
LJY is offline   Reply With Quote
Old 11-17-2017, 03:12 PM   #17
LJY
Senior Member
 
Join Date: Mar 2016
Location: Nor, California
Trailer: 2017 Escape
Posts: 200
Finally got around to installing this.. after waiting for rain to stop. It's working now after the circuit board replacement. But I feel like there's some design flaw that allows the condensation to drip down to the board and damage it...
LJY is offline   Reply With Quote
Old 11-17-2017, 08:41 PM   #18
Senior Member
 
Join Date: Mar 2013
Location: none, Washington, D.C.
Trailer: None
Posts: 1,025
Quote:
Originally Posted by jennykatz View Post
My maxxfan seems to be making a clicking sound and as I ramp up speed it gets louder ? I wonder if the bearings in the motor are going ? We are still under warranty . how hard is it to take motor off the fan part and take it to a maxxfan service center ?
The noise could be from the fan blade hitting the housing / fan shroud.
I had the same issue and was able to resolve it by shimming the fan unit. Much cheaper than a new fan or fan motor .

Best of luck
__________________

steve dunham is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






» Virginia Campgrounds

Reviews provided by



All times are GMT -5. The time now is 08:16 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 Social Knowledge, LLC All Rights Reserved.