Stock radio - Escape Trailer Owners Community

Go Back   Escape Trailer Owners Community > Escape Tech > Problem Solving | Owners helping each other
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 02-04-2014, 11:45 PM   #1
Member
 
Minnie's Avatar
 
Join Date: Feb 2009
Location: Gabriola Island, BC, British Columbia
Trailer: 2013 Escape 5.0
Posts: 97
Stock radio

So, we foolishly opted for the stock radio in our new 5.0 after Tammy told us that she hadn't heard any complaints. Less than 6 months in, it has died after "swallowing" a cd. According to the manual, in which the picture bears no resemblance to our unit, there should be a reset switch.

Does anyone know where such an animal resides in the radio or, better yet, how to get the front off?

Thanks!
Christine
__________________

__________________
Christine & Les
2013 Escape 5.0
2012 Toyota Tacoma
Minnie is offline   Reply With Quote
Old 02-05-2014, 06:17 AM   #2
Site Team
 
Donna D.'s Avatar
 
Join Date: Nov 2008
Location: Portland, Oregon
Trailer: 2014 Escape 5.0 TA
Posts: 6,820
Christine, can you post the brand and model number? If no one answers up, the WWW is full of manufacturers and users manuals.

The CD player in my truck swallowed a CD too. It's just something they do sometimes. Even my Mom's Bose did it after the first WEEK.

I don't think you were foolish at all.
__________________

Donna D. is offline   Reply With Quote
Old 02-05-2014, 08:04 AM   #3
Senior Member
 
onetim's Avatar
 
Join Date: May 2012
Location: Tiverton, Rhode Island
Trailer: 2013 Escape 5.0
Posts: 106
I have no experience with your particular radio, however, most CD players have a small hole on the front where you can insert a paper clip to manually eject the CD.
__________________
Tim
Rhode Island
July 2013 Escape 5.0 / 2012 Nissan Frontier
onetim is offline   Reply With Quote
Old 02-05-2014, 09:21 PM   #4
Member
 
Minnie's Avatar
 
Join Date: Feb 2009
Location: Gabriola Island, BC, British Columbia
Trailer: 2013 Escape 5.0
Posts: 97
Thanks, Donna, for the vote of confidence! But I am a bit foolish because others on this forum have complained about this radio. I just thought if they hadn't said anything to Tammy then it wasn't that serious. But now I have no radio. Nada.
It's a Touch Audio VD-301. I have the manual and I've checked on line and got the same manual. And other people complaining about it.
Thanks, onetim, but there is no little hole on the front for manual eject.
Not to worry. I have to take the trailer back to Chilliwack for some self-inflicted damage (don't ask) so I'll ask Reace or Dave to work their magic :-)
__________________
Christine & Les
2013 Escape 5.0
2012 Toyota Tacoma
Minnie is offline   Reply With Quote
Old 02-05-2014, 09:35 PM   #5
Site Team
 
Donna D.'s Avatar
 
Join Date: Nov 2008
Location: Portland, Oregon
Trailer: 2014 Escape 5.0 TA
Posts: 6,820
You brought up a good point. ETI can't fix what they don't know is broken! It's up to us, the consumer, to point out problems. We KNOW ETI wants to build the best product on the market for the price and they don't want to hear about complaints AFTER THE FACT. So please, everyone if you have any kind of problem with anything, give ETI a chance to correct it for future owners (like me!).
Donna D. is offline   Reply With Quote
Old 02-05-2014, 09:41 PM   #6
Senior Member
 
gbaglo's Avatar
 
Join Date: Oct 2008
Location: North Vancouver, British Columbia
Trailer: 2009 Escape 17B - "Toad". '08 Toyota RAV4 V6
Posts: 10,715
Would still be under warranty, wouldn't it?
__________________
2009 Escape 17B "Toad"
2008 Toyota RAV4 V6 Sport
North Vancouver, British Columbia

What happens to the hole when the cheese is gone?
- Bertolt Brecht
gbaglo is offline   Reply With Quote
Old 02-05-2014, 11:11 PM   #7
Senior Member
 
Dave Walter's Avatar
 
Join Date: Apr 2012
Location: Edmonton, Alberta
Trailer: 2013 Escape 19 & 15B
Posts: 1,869
There was a thread awhile back where I questioned whether this radio is worth getting. Any Regrets with Factory "Touch Audio" Stereo Based on discussions, we bought another product (JHD910BT) and had Reace install it during the build. No regrets.
__________________
2013-19' & 2013-15B {avg is two 17's}, towed by 2011 Toyota FJ Cruiser

"It is better to remain silent at the risk of being thought a fool, than to talk and remove all doubt of it." - 1907, Maurice Switzer
Dave Walter is offline   Reply With Quote
Old 02-05-2014, 11:44 PM   #8
Member
 
Minnie's Avatar
 
Join Date: Feb 2009
Location: Gabriola Island, BC, British Columbia
Trailer: 2013 Escape 5.0
Posts: 97
Oh dear. Based on ice-breaker's comment, I guess I'm just not intelligent enough for this forum. :-( Silly me for not listening to a few whinges over Tammy's experience with no one actually taking the time to complain officially. Sorry, it's been a long day full of people who know what's best ......

Thanks, Glenn and Donna. I'll look into the warranty thing (there's no card with the ETI stuff) and let Tammy know of the issue when I'm in Chilliwack.

I'll go away now.
Christine
__________________
Christine & Les
2013 Escape 5.0
2012 Toyota Tacoma
Minnie is offline   Reply With Quote
Old 02-05-2014, 11:46 PM   #9
Site Team
 
cpaharley2008's Avatar
 
Join Date: Jun 2010
Location: York, Pennsylvania
Trailer: 2016 2ndGen Escape 19' PRAIRIE SCHOONER pulled by 2014 Ram Hemi/8sp
Posts: 13,654
Quote:
Originally Posted by gbaglo View Post
Would still be under warranty, wouldn't it?
The trailer has it's own warranty as do the individual components, e.g..the water heater, furnace, refer, radio. I think you have to deal with the component manufacturer. If unsuccessful, ETI may then step in as good customer relations, but they are under no obligation for the components which carry their own warranties.
__________________
Jim
The two most important days in your life are the day you were born and the day you find out why………..Mark Twain
cpaharley2008 is offline   Reply With Quote
Old 02-05-2014, 11:55 PM   #10
Senior Member
 
Dave Walter's Avatar
 
Join Date: Apr 2012
Location: Edmonton, Alberta
Trailer: 2013 Escape 19 & 15B
Posts: 1,869
Quote:
Originally Posted by Minnie View Post
Oh dear. Based on ice-breaker's comment, I guess I'm just not intelligent enough for this forum. :-( Silly me for not listening to a few whinges over Tammy's experience with no one actually taking the time to complain officially. Sorry, it's been a long day full of people who know what's best ......

Thanks, Glenn and Donna. I'll look into the warranty thing (there's no card with the ETI stuff) and let Tammy know of the issue when I'm in Chilliwack.

I'll go away now.
Christine
Minnie, please don't take my post as being critical of your choice. I simply wanted to point out that there has been some discussion of this radio in the past. Even in the previous thread there were some posters that were satisfied with the factory supplied radio. I simply chose another option.
__________________

__________________
2013-19' & 2013-15B {avg is two 17's}, towed by 2011 Toyota FJ Cruiser

"It is better to remain silent at the risk of being thought a fool, than to talk and remove all doubt of it." - 1907, Maurice Switzer
Dave Walter is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






» Virginia Campgrounds

Reviews provided by



All times are GMT -5. The time now is 08:22 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 Social Knowledge, LLC All Rights Reserved.