Furrion RV camera Issue - Escape Trailer Owners Community
Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×

Go Back   Escape Trailer Owners Community > Escape Tech > Problem Solving | Owners helping each other
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 04-15-2024, 05:06 PM   #1
Junior Member
 
Join Date: Sep 2022
Location: Minneapolis, Minnesota
Trailer: 2023 Escape 21NE F2
Posts: 29
Furrion RV camera Issue

We picked up our 2023 21 NE last July in Sumas and everything worked A-OK throughout last summer. In late October, we stored the trailer outdoors for the mildest Minnesota winter I've ever experienced and I unscrewed and removed the antenna on the Furrion Vision 5 camera before we covered the trailer with a Calmark cover for 5 months.
We wanted to see the Eclipse last week so I got the trailer out of storage and after sanitizing the tanks and de-winterizing it, I re-attached the camera antenna and found we have no signal between the camera and monitor. They appear to be paired, but there is no signal. The headlights were on as required. We still had a great trip to SE Illinois and saw the eclipse. I was able to back into the campsites we visited with no issue but I missed having the camera. We have the same tow vehicle as last year, a 2021 F150. Any idea why the camera no longer works? Or should I contact Furrion about this?
John From MN is offline   Reply With Quote
Old 04-15-2024, 06:48 PM   #2
Member
 
Join Date: Jun 2017
Location: Central valley, California
Trailer: 2021 Escape 5.0
Posts: 93
My 2016 Ford F150 has two settings for the headlights. A forced-on and an auto-on when dark setting. During the day, my camera needs the forced-on setting. I forget this every so often…maybe something to check.
Jwinfrey is offline   Reply With Quote
Old 04-15-2024, 06:54 PM   #3
Junior Member
 
joebuoy's Avatar
 
Join Date: Mar 2017
Location: Kent, Washington
Trailer: 2023 E19
Posts: 22
The display is capable of supporting several cameras. Check to see if the rear camera option on the screen is selected (far right bottom). I experienced a similar issue of no signal until I selected the correct camera option.
joebuoy is offline   Reply With Quote
Old 04-15-2024, 07:11 PM   #4
Junior Member
 
Join Date: Sep 2022
Location: Minneapolis, Minnesota
Trailer: 2023 Escape 21NE F2
Posts: 29
Quote:
Originally Posted by Jwinfrey View Post
My 2016 Ford F150 has two settings for the headlights. A forced-on and an auto-on when dark setting. During the day, my camera needs the forced-on setting. I forget this every so often…maybe something to check.

Thanks. I've tried it in both forced-on and auto-on over the last 10 days on our trip with no joy.
John From MN is offline   Reply With Quote
Old 04-15-2024, 07:13 PM   #5
Junior Member
 
Join Date: Sep 2022
Location: Minneapolis, Minnesota
Trailer: 2023 Escape 21NE F2
Posts: 29
Quote:
Originally Posted by joebuoy View Post
The display is capable of supporting several cameras. Check to see if the rear camera option on the screen is selected (far right bottom). I experienced a similar issue of no signal until I selected the correct camera option.

The monitor is paired with the rear camera. I have tried selecting each camera individually as well as "all cameras". No luck.
John From MN is offline   Reply With Quote
Old 04-15-2024, 07:44 PM   #6
Senior Member
 
jack sparrow's Avatar
 
Join Date: Mar 2023
Location: Near New Orleans, Louisiana
Trailer: 2023 Escape 21NE "Escape to Margaritaville"
Posts: 200
If you haven't done so already, you might want to re-pair it with the monitor.
Just ruling out anything possible, last ditch effort I guess.
And is the blue power light on, on the camera to verify you have power there. easy checks.


Good luck.....


Cheers to ya..... and Happy Trails....... Jack
jack sparrow is offline   Reply With Quote
Old 04-15-2024, 07:50 PM   #7
Senior Member
 
Join Date: Jan 2021
Location: Hazelwood, Missouri
Trailer: 2021 5.0
Posts: 794
Quote:
Originally Posted by John From MN View Post
The monitor is paired with the rear camera. I have tried selecting each camera individually as well as "all cameras". No luck.
For further testing it can be plugged directly into the monitor.
You just have to take the camera off of the mount and it will bypass the wireless function.
Ooshkaboo is offline   Reply With Quote
Old 04-15-2024, 07:53 PM   #8
Junior Member
 
Join Date: Sep 2022
Location: Minneapolis, Minnesota
Trailer: 2023 Escape 21NE F2
Posts: 29
Quote:
Originally Posted by jack sparrow View Post
If you haven't done so already, you might want to re-pair it with the monitor.
Just ruling out anything possible, last ditch effort I guess.
And is the blue power light on, on the camera to verify you have power there. easy checks.


Good luck.....


Cheers to ya..... and Happy Trails....... Jack

Thanks but I tried it. The monitor appears paired with the camera. Re-pairing it made no apparent difference.
John From MN is offline   Reply With Quote
Old 04-15-2024, 09:36 PM   #9
Senior Member
 
Join Date: Nov 2021
Location: Calgary, Alberta
Trailer: 2023 E19
Posts: 323
I had an issue with an intermittent connection last year. It turned out to be a loose antenna on the camera. Once I tightened it up, it resumed working without issue.

Since you stated you removed the antenna during winter storage, I'd examine that connection closely. Perhaps the antenna or connector is damaged....or just not fully tightened.

Fortunately, It looks like a replacement antenna is quite inexpensive, should one be required.
Selkirk is offline   Reply With Quote
Old 04-16-2024, 08:30 AM   #10
Junior Member
 
Join Date: Sep 2022
Location: Minneapolis, Minnesota
Trailer: 2023 Escape 21NE F2
Posts: 29
Quote:
Originally Posted by Ooshkaboo View Post
For further testing it can be plugged directly into the monitor.
You just have to take the camera off of the mount and it will bypass the wireless function.



Thanks!
John From MN is offline   Reply With Quote
Old 04-16-2024, 08:32 AM   #11
Junior Member
 
Join Date: Sep 2022
Location: Minneapolis, Minnesota
Trailer: 2023 Escape 21NE F2
Posts: 29
Quote:
Originally Posted by Selkirk View Post
I had an issue with an intermittent connection last year. It turned out to be a loose antenna on the camera. Once I tightened it up, it resumed working without issue.

Since you stated you removed the antenna during winter storage, I'd examine that connection closely. Perhaps the antenna or connector is damaged....or just not fully tightened.

Fortunately, It looks like a replacement antenna is quite inexpensive, should one be required.



Thanks! We're having some windy and rainy weather here so I won't be getting on the ladder to investigate this for a couple days...
John From MN is offline   Reply With Quote
Old 04-21-2024, 05:25 PM   #12
Junior Member
 
Join Date: Sep 2022
Location: Minneapolis, Minnesota
Trailer: 2023 Escape 21NE F2
Posts: 29
I took camera off the back of the trailer as it appears it was not getting any power (headlights were on, not in auto).

Does anyone know how the camera wiring is routed and if there might be an in-line fuse somewhere I can check? I looked under the front dinette benches and nothing leaped out at me.
John From MN is offline   Reply With Quote
Old 04-21-2024, 05:44 PM   #13
Junior Member
 
Join Date: Sep 2022
Location: Minneapolis, Minnesota
Trailer: 2023 Escape 21NE F2
Posts: 29
Quote:
Originally Posted by Ooshkaboo View Post
For further testing it can be plugged directly into the monitor.
You just have to take the camera off of the mount and it will bypass the wireless function.

We must have different cameras. I have the Furrion Vision S and you cannot plug the camera directly into the monitor. However, the power supply has a pigtail on it for testing the camera (I always wondered what the pigtail was for! It's not mentioned in any of the paperwork I received) Anyways, it appears the camera works fine, but the power supply from the trailer no longer works. The search continues...
Attached Thumbnails
Furrion.jpg  
John From MN is offline   Reply With Quote
Old 04-21-2024, 06:04 PM   #14
Senior Member
 
brroberts's Avatar
 
Join Date: May 2020
Location: Overbrook, Kansas
Trailer: 2021 E19 (Padawan)
Posts: 2,091
ETI service is likely able to tell you where they tap for camera power. I’d guess rear lights somewhere, but have never looked.
__________________
Randy & Barb
1998 C 2500 (Cruncher) and 2021 Ranger (Yoda)
brroberts is offline   Reply With Quote
Old 04-21-2024, 07:30 PM   #15
Senior Member
 
Join Date: Jan 2021
Location: Hazelwood, Missouri
Trailer: 2021 5.0
Posts: 794
Quote:
Originally Posted by John From MN View Post
We must have different cameras. I have the Furrion Vision S and you cannot plug the camera directly into the monitor. However, the power supply has a pigtail on it for testing the camera (I always wondered what the pigtail was for! It's not mentioned in any of the paperwork I received) Anyways, it appears the camera works fine, but the power supply from the trailer no longer works. The search continues...
Yes that is what I meant by plugging into the camera, it bypasses the bluetooth.

In the back of a 5.0 the camera wiring is accessible at the rear behind this vertical panel, driver side. It’s a thin black wire which then splits into two smaller wires as it comes down from the camera, white and red I believe. It runs straight down to underneath the bench seat.
While I had mine apart I installed an on off switch to one of my drop lines so I could use it as a security camera at night, bypassing the need for the TV to be hooked up and running.

I bring my monitor to the bedroom at night, another female plug hooked up to yet another drop line. While I was at it I installed another camera to the front of the camper.
Attached Thumbnails
image.jpg  
Ooshkaboo is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Escape Trailer Industries or any of its affiliates. This is an independent, unofficial site.


All times are GMT -5. The time now is 09:09 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
Copyright 2023 Social Knowledge, LLC All Rights Reserved.