MaxxFan and no customer service - Escape Trailer Owners Community

Go Back   Escape Trailer Owners Community > Escape Tech > Problem Solving | Owners helping each other
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 07-27-2020, 05:00 PM   #1
Junior Member
 
Join Date: Jun 2019
Location: Colorado, Colorado
Trailer: N/A
Posts: 5
MaxxFan and no customer service

Hello;
I hope you are all well today.

Our MaxxFan has quit working, Airxcel is nowhere to be found, and Escape is referring me back to Airxcel...I know, its shocking.

The fan is a MaxxFan Deluxe 5100K.

The problem, in short, is that shortly after the fan is turned on it begins to slow down eventually coming to a complete stop. If you remove the fan screen and push the fan blades (with the fan still switched on) the fan will begin again, only to slow down moments later and stop again. After a few rotations of this process, sometimes the fan just does not restart, and sometimes you can keep this process going for hours!

The problem is unchanged regardless of doors or windows being open or closed, and regardless of battery/solar power or shore power. All other electrical components are working fine as well.

It seems to me that the motor needs replacing, or at least start there.
Escape can send me an entirely new fan, but it will cost well over $350 after shipping. Airxcel is not responding to me.

We are leaving for a road trip in a few days and I am now out of time after fruitlessly waiting on Airxcel to help. I need to get this #$%&!@# thing fixed!

Any thoughts on a repair or where to find a replacement motor? Should I just bite the bullet and order an entirely new fan from Escape? Are there alternate fan companies with better customer service?

Thanks a million for your help in advance!
CW
__________________

offpistetele is offline   Reply With Quote
Old 07-27-2020, 05:03 PM   #2
Senior Member
 
TTMartin's Avatar
 
Join Date: Mar 2020
Location: Punta Gorda, Florida
Trailer: 2020 Escape 19
Posts: 302
Quote:
Originally Posted by offpistetele View Post
Hello;
I hope you are all well today.

Our MaxxFan has quit working, Airxcel is nowhere to be found, and Escape is referring me back to Airxcel...I know, its shocking.

The fan is a MaxxFan Deluxe 5100K.

The problem, in short, is that shortly after the fan is turned on it begins to slow down eventually coming to a complete stop. If you remove the fan screen and push the fan blades (with the fan still switched on) the fan will begin again, only to slow down moments later and stop again. After a few rotations of this process, sometimes the fan just does not restart, and sometimes you can keep this process going for hours!

The problem is unchanged regardless of doors or windows being open or closed, and regardless of battery/solar power or shore power. All other electrical components are working fine as well.

It seems to me that the motor needs replacing, or at least start there.
Escape can send me an entirely new fan, but it will cost well over $350 after shipping. Airxcel is not responding to me.

We are leaving for a road trip in a few days and I am now out of time after fruitlessly waiting on Airxcel to help. I need to get this #$%&!@# thing fixed!

Any thoughts on a repair or where to find a replacement motor? Should I just bite the bullet and order an entirely new fan from Escape? Are there alternate fan companies with better customer service?

Thanks a million for your help in advance!
CW
Does it do the same thing if you reverse it to blow in?
__________________

TTMartin is offline   Reply With Quote
Old 07-27-2020, 05:07 PM   #3
Junior Member
 
Join Date: Jun 2019
Location: Colorado, Colorado
Trailer: N/A
Posts: 5
Yes! Thanks for the point of clarification.

Regardless of direction...suck or blow...(am I allowed to say that on this forum) it behaves the same.

CW
offpistetele is offline   Reply With Quote
Old 07-27-2020, 05:12 PM   #4
Senior Member
 
TTMartin's Avatar
 
Join Date: Mar 2020
Location: Punta Gorda, Florida
Trailer: 2020 Escape 19
Posts: 302
Quote:
Originally Posted by offpistetele View Post
Yes! Thanks for the point of clarification.

Regardless of direction...suck or blow...(am I allowed to say that on this forum) it behaves the same.

CW
I hope so because that sucks and blows that the fan doesn't.
TTMartin is offline   Reply With Quote
Old 07-27-2020, 05:16 PM   #5
Site Team
 
padlin's Avatar
 
Join Date: Sep 2009
Location: Southwick, Massachusetts
Trailer: 5.0 TA #6, 2012 F150 EB
Posts: 6,678
Temp setting makes no difference?
__________________
Happy Motoring
Bob
padlin is offline   Reply With Quote
Old 07-27-2020, 05:20 PM   #6
Junior Member
 
Join Date: Jun 2019
Location: Colorado, Colorado
Trailer: N/A
Posts: 5
Quote:
Originally Posted by padlin View Post
Temp setting makes no difference?
That is a good question. And in short, I cannot tell...the button responds and the light turns on to indicate the thermostat is on. But because of how it is starting and stopping I do not know if it is the thermostat is working...

Now that I am replying to this question, I am wondering if this could be the control board alternatively?
offpistetele is offline   Reply With Quote
Old 07-27-2020, 05:28 PM   #7
Site Team
 
cpaharley2008's Avatar
 
Join Date: Jun 2010
Location: Central, Pennsylvania
Trailer: Escape#4, 2019 Escape21 DejaView pulled by 2014 Ram Hemi/8sp
Posts: 22,654
While here please update your avatar to reflect Escape model. There are several threads about replacing board due to over voltage or condensation shorting out the board. It is suggested you coat the new board replacement.
__________________
Jim
Sometimes life gets in the way of living......
cpaharley2008 is offline   Reply With Quote
Old 07-27-2020, 05:46 PM   #8
Senior Member
 
TTMartin's Avatar
 
Join Date: Mar 2020
Location: Punta Gorda, Florida
Trailer: 2020 Escape 19
Posts: 302
Quote:
Originally Posted by offpistetele View Post
That is a good question. And in short, I cannot tell...the button responds and the light turns on to indicate the thermostat is on. But because of how it is starting and stopping I do not know if it is the thermostat is working...

Now that I am replying to this question, I am wondering if this could be the control board alternatively?
With it set to manual not thermostat, I assume you've stepped the fan speed up and down to see of that makes a difference?
TTMartin is offline   Reply With Quote
Old 07-27-2020, 05:49 PM   #9
Senior Member
 
Join Date: Aug 2013
Location: Naples, Florida
Trailer: New 21 Escape (not classic)10/16 Sold Lil Snoozy 7/16
Posts: 442
Maxfann

We had a problem with our Maxfann the top of the fan split and was letting water in when it rained So I used JB weld and fixed temporarily and then sent maxfann/ an e mail and they sent me a new replacement top for free this was last year We have a 2016 E21 So maybe send an Email instead of phone ? JimW
jennykatz is offline   Reply With Quote
Old 07-27-2020, 05:50 PM   #10
Senior Member
 
TTMartin's Avatar
 
Join Date: Mar 2020
Location: Punta Gorda, Florida
Trailer: 2020 Escape 19
Posts: 302
Quote:
Originally Posted by TTMartin View Post
With it set to manual not thermostat, I assume you've stepped the fan speed up and down to see of that makes a difference?
TTMartin is offline   Reply With Quote
Old 07-27-2020, 06:11 PM   #11
Senior Member
 
Join Date: Mar 2018
Location: Tulsa, Oklahoma
Trailer: 2013 Li'l Hauley
Posts: 359
Is the maxx fan still under warranty?


With a trip coming up, I would go to a local rv repair facility (other than Camping World) and obtain a replacement fan. Either put in myself or pay to have it installed, but either way I wouldn't wait around any longer. Perhaps the shop would diagnose and replace just a bad part, but if not, just get a new one and be done.



If it's under warranty still, the repair shop might aid you in getting reimbursement or even do it without charge on the basis that they will get reimbursed (they might have an established procedure for submitting claims to the mfr).


If it's not under warranty, there's always the option of replacing it with a Fantastic Fan instead of another Maxx.
__________________
Losing weight puts one at much greater risk of becoming thin.
Mike G is offline   Reply With Quote
Old 07-27-2020, 06:23 PM   #12
Senior Member
 
tdf-texas's Avatar
 
Join Date: Nov 2015
Location: Baytown, Texas
Trailer: 2017 21' Escape - since 1/9/2017
Posts: 1,771
Quote:
Originally Posted by offpistetele View Post
Hello;
I hope you are all well today.

Our MaxxFan has quit working, Airxcel is nowhere to be found, and Escape is referring me back to Airxcel...I know, its shocking.

The fan is a MaxxFan Deluxe 5100K.

The problem, in short, is that shortly after the fan is turned on it begins to slow down eventually coming to a complete stop. If you remove the fan screen and push the fan blades (with the fan still switched on) the fan will begin again, only to slow down moments later and stop again. After a few rotations of this process, sometimes the fan just does not restart, and sometimes you can keep this process going for hours!

The problem is unchanged regardless of doors or windows being open or closed, and regardless of battery/solar power or shore power. All other electrical components are working fine as well.

It seems to me that the motor needs replacing, or at least start there.
Escape can send me an entirely new fan, but it will cost well over $350 after shipping. Airxcel is not responding to me.

We are leaving for a road trip in a few days and I am now out of time after fruitlessly waiting on Airxcel to help. I need to get this #$%&!@# thing fixed!

Any thoughts on a repair or where to find a replacement motor? Should I just bite the bullet and order an entirely new fan from Escape? Are there alternate fan companies with better customer service?

Thanks a million for your help in advance!
CW
Here is a source to get a replacement control board for the 5100K.
https://www.adventurerv.net/printed-...t-p-41753.html

Here is a link to the repair parts list.
https://www.airxcel.com/docs/default...vrsn=1cc016b_6

There is a very high likelyhood your motor is good but the control board has failed. You probably will want to do several things when you replace the control board.

1. Seal the hole with sealant (Proflex) directly above the Maxxair control board that has the motor leads coming through it. Condensation tends to drip down on the frame, collects on the motor bracket, and then drips right on top of the control board rendering it inoperable.

2. Apply some conformal coating to the control board before installing it. Coat both sides. Here are some sources for conformal coating.
https://www.amazon.com/gp/product/B0...?ie=UTF8&psc=1 (this is the stuff I use)
https://www.amazon.com/MG-Chemicals-.../dp/B06XWGCKX5 (if you like spray coating better)
__________________
If It Isn’t Perfect, It Isn’t Finished
tdf-texas is offline   Reply With Quote
Old 07-28-2020, 07:56 AM   #13
Junior Member
 
Join Date: Jun 2019
Location: Colorado, Colorado
Trailer: N/A
Posts: 5
Thanks a million for everyone’s input. This has been super helpful! I will try your recommendation and keep y’all posted.
CW
offpistetele is offline   Reply With Quote
Old 07-28-2020, 12:04 PM   #14
Senior Member
 
Join Date: Jan 2014
Location: North Van., British Columbia
Trailer: 2014 Escape 19, sold; 2019 Escape 21, Sept. 2019
Posts: 5,569
Quote:
Originally Posted by offpistetele View Post
That is a good question. And in short, I cannot tell...the button responds and the light turns on to indicate the thermostat is on. But because of how it is starting and stopping I do not know if it is the thermostat is working...

Now that I am replying to this question, I am wondering if this could be the control board alternatively?
This is contrary to my experience with them a couple of months ago. Phone is hopeless. Email worked fine and they sent me a new circuit board.

Ron
Ron in BC is offline   Reply With Quote
Old 07-28-2020, 12:11 PM   #15
Senior Member
 
gbaglo's Avatar
 
Join Date: Oct 2008
Location: North Vancouver, British Columbia
Trailer: 2009 Escape 17B - "Toad". '08 Toyota RAV4 V6
Posts: 14,933
Quote:
Originally Posted by Ron in BC View Post
This is contrary to my experience with them a couple of months ago. Phone is hopeless. Email worked fine and they sent me a new circuit board.

Ron

Likely the result of the pandemic with people working from home ( email ) and nobody in the office ( phone ).
__________________
2009 Escape 17B "Toad"
2008 Toyota RAV4 V6 Sport
North Vancouver, British Columbia

What happens to the hole when the cheese is gone?
- Bertolt Brecht
gbaglo is offline   Reply With Quote
Old 07-28-2020, 08:43 PM   #16
Senior Member
 
Eggscape's Avatar
 
Join Date: Oct 2017
Location: Kelowna, British Columbia
Trailer: 2018 Escape 19
Posts: 1,628
I would first check that you have full voltage to fan. Maybe there is a poor connection between the battery and fan. Enough to get it going but as it continues the poor connection heats up and will not pass the current.
Good luck.
__________________
So many modifications...so little time.

https://www.escapeforum.org/forums/f8...ape-12918.html
Eggscape is offline   Reply With Quote
Old 07-28-2020, 09:37 PM   #17
Member
 
Join Date: Mar 2017
Location: Northern Nevada, Nevada
Trailer: 2014 Escape 15A
Posts: 58
I just purchased a new MaxxFan 4000 from Camping World, installed it and discovered it has a dead short within the fan; defective right out of the box.

2-days and counting w/o reply from CW and you can forget about trying to talk to someone. So, I guess I'll leave it installed for our upcoming trip next week and deal with it later.

There might be a few units in the supply chain but after checking with 1/2 dozen vendors...its not in stock/backordered.
__________________

dstreight is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Escape Trailer Industries or any of its affiliates. This is an independent, unofficial site.


All times are GMT -5. The time now is 09:52 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Copyright 2012 Social Knowledge, LLC All Rights Reserved.
×