Flickering LED Lights - Page 3 - Escape Trailer Owners Community

Go Back   Escape Trailer Owners Community > Escape Community > Escape News
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 04-16-2014, 03:28 PM   #21
Senior Member
 
escape artist's Avatar
 
Join Date: Oct 2008
Location: St. Thomas not BVI., Ontario
Trailer: 2014 Escape 5.0TA
Posts: 5,297
Hi: MarksAlot... Did you name her "Escape Therapy"? Alf
escape artist N.S. of Lake Erie
__________________

__________________
Quote Bugs Bunny..."Don't take life too seriously, none of us get out of it ALIVE"!!!
'10 Frontier CC. S.E. 4X4 Lng. Bed V6 '14 Escape 5.0TA
St.Thomas Ont.( Not the Virgin Islands)
escape artist is online now   Reply With Quote
Old 04-16-2014, 03:36 PM   #22
Senior Member
 
MarksAlot's Avatar
 
Join Date: Dec 2013
Location: Clovis, California
Trailer: 2014 Escape 19
Posts: 328
Quote:
Originally Posted by escape artist View Post
Hi: MarksAlot... Did you name her "Escape Therapy"? Alf
escape artist N.S. of Lake Erie

Excellent idea! Thank you. I invite you to her christening when I get her home. The wine will flow!
__________________

__________________
Don't make excuses for failure, seek ways to succeed.

Mark
Blizzy and Dakota (Da Boyz)
MarksAlot is offline   Reply With Quote
Old 05-19-2014, 11:08 PM   #23
Junior Member
 
Join Date: Jun 2012
Location: Beaverton/Aloha, Oregon
Trailer: 2011 17B
Posts: 10
From someone who still remembers relay contact burnishers

Don't use a knife on the contacts. That will work for a bit by getting to clean metal but it has also taken off the silver/ plating done to the contacts resulting in another failure further down the line.

Per a post above, it is better to use a pencil eraser for this it cleans the contact without scraping off the contact metal.

Yes, I have done this on circuit boards for a long time. Learned the trick from field service.
lieb is offline   Reply With Quote
Old 10-11-2014, 07:46 PM   #24
Senior Member
 
LeonW's Avatar
 
Join Date: Aug 2011
Location: St. Paul, Minnesota
Trailer: 2014 Escape 21 -- The Skylark. Towed by a 2014 Highlander
Posts: 981
After we picked up our 21, we noticed that the LEDs flickered when we ran the water pump, and one of them flickered intermittently even when the water pump was not running, inspite of trying an eraser on the contacts.

I checked the battery connections, and found that all the connections were a little loose. So I tightened them, and that seems to have solved the problem.

I am posting this here in hopes that if anyone else has the problem it will give them a hint for a possible solution.
__________________

LeonW is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






» Virginia Campgrounds

Reviews provided by



All times are GMT -5. The time now is 03:32 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 Social Knowledge, LLC All Rights Reserved.