Bath Vent Fan on 19 - Page 2 - Escape Trailer Owners Community

Go Back   Escape Trailer Owners Community > Escape Tech > Modifications and Alterations
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 02-21-2016, 11:30 PM   #11
Senior Member
 
rbryan4's Avatar
 
Join Date: Jun 2014
Location: San Antonio, Texas
Trailer: 2015 19 "Past Tents", 2015 F150 Ecoboost
Posts: 6,173
Nice work Doug. I'm glad ours came with one.
__________________

__________________
"You can't buy happiness, but you can buy an RV. And that is pretty close."
rbryan4 is offline   Reply With Quote
Old 09-06-2016, 02:55 PM   #12
Member
 
Join Date: Mar 2015
Location: Federal Way, Washington
Trailer: 2015 Escape 21/ 09 2015
Posts: 70
For the ETI installed Ventline bath fan where is the 15A fuse located? It is not labeled in the fuse box. I am just trying to exhaust (haha) all possibilities for my non-working fan before replacing.
__________________

luckyone is offline   Reply With Quote
Old 09-06-2016, 08:30 PM   #13
Senior Member
 
float5's Avatar
 
Join Date: Nov 2010
Location: Denison, Texas
Trailer: 2015 21'; 2011 19' sold; 4Runner; ph ninezero3 327-27ninefour
Posts: 4,017
Quote:
Originally Posted by luckyone View Post
For the ETI installed Ventline bath fan where is the 15A fuse located? It is not labeled in the fuse box. I am just trying to exhaust (haha) all possibilities for my non-working fan before replacing.
You have a 2015? Did you call Escape? So it was working until recently?
Escapes previously did not have bath fans, by the way, just the vent. I am glad to have the fan, as long as it works.
__________________
Cathy. Floating Cloud
"Live in the sunshine, swim the sea, drink the wild air.... "
Emerson
float5 is offline   Reply With Quote
Old 09-07-2016, 12:50 PM   #14
Member
 
Join Date: Mar 2015
Location: Federal Way, Washington
Trailer: 2015 Escape 21/ 09 2015
Posts: 70
Quote:
Originally Posted by float5 View Post
You have a 2015? Did you call Escape? So it was working until recently?
Escapes previously did not have bath fans, by the way, just the vent. I am glad to have the fan, as long as it works.
Yes. This is a 2015 with the bathroom fan. I have contacted Escape and Tammy sent me a new Ventline Fan promptly. I was just trying to make sure that it wasn't anything simple (like a blown fuse)before it is replaced. I know that there is also a thermal fuse inside the fan that could be the problem as well.
luckyone is offline   Reply With Quote
Old 09-07-2016, 01:03 PM   #15
Senior Member
 
paulw's Avatar
 
Join Date: Feb 2010
Location: Marysville, Washington
Trailer: 2014 Escape 21 & Chevy Silverado 5.3L EcoTec
Posts: 597
Quote:
Originally Posted by luckyone View Post
Yes. This is a 2015 with the bathroom fan. I have contacted Escape and Tammy sent me a new Ventline Fan promptly. I was just trying to make sure that it wasn't anything simple (like a blown fuse)before it is replaced. I know that there is also a thermal fuse inside the fan that could be the problem as well.
We are on our 3rd Ventline - the first was a source of a leak and was replaced under warranty shortly after we picked up our 2014.
The second one stopped working a couple months ago. I was going to pull it apart and try to fix it (suspected the switch) but I had the trailer up to ETI for a raised dinette floor and just had them replace it. I didn't see a fuse when I was poking around, but the switch didn't seem very robust and is kinda exposed.
paulw is offline   Reply With Quote
Old 09-07-2016, 01:08 PM   #16
Member
 
Join Date: Mar 2015
Location: Federal Way, Washington
Trailer: 2015 Escape 21/ 09 2015
Posts: 70
Quote:
Originally Posted by paulw View Post
We are on our 3rd Ventline - the first was a source of a leak and was replaced under warranty shortly after we picked up our 2014.
The second one stopped working a couple months ago. I was going to pull it apart and try to fix it (suspected the switch) but I had the trailer up to ETI for a raised dinette floor and just had them replace it. I didn't see a fuse when I was poking around, but the switch didn't seem very robust and is kinda exposed.
Thanks for that Paul. Fortunately we are so close that we can run it up and have it done at ETI. I am going to check the fuse with a multi-meter and be done with it. The fan has never worked.
__________________

luckyone is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






» Virginia Campgrounds

Reviews provided by



All times are GMT -5. The time now is 03:12 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 Social Knowledge, LLC All Rights Reserved.