7 Pin Plug Fit - Page 2 - Escape Trailer Owners Community

Go Back   Escape Trailer Owners Community > Escape Tech > Problem Solving | Owners helping each other
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 06-02-2015, 12:02 AM   #11
Senior Member
 
Join Date: Dec 2012
Location: Edmonton, Alberta
Trailer: 1979 Boler B1700
Posts: 9,036
Quote:
Originally Posted by Seef View Post
Don't know of iT is available in your neck of the woods but switching over to the 13 pin jaeger plug does solve your problem at once. IT twists in the receiver and locks itself.
Those current European 13-pin plugs and sockets (ISO 11446) look like a nice system... but I would be very surprised to find one here.

The pins and wires are relatively small in the Euro connections, in part because the power supply and ground are split between multiple circuits each, and in part because the electric brake connnection is not used. Seef, you are using electric brakes on your Escape 5.0... are you using a non-standard pin assignment in your connector?
__________________

Brian B-P is offline   Reply With Quote
Old 06-02-2015, 12:08 AM   #12
Senior Member
 
Join Date: Dec 2012
Location: Edmonton, Alberta
Trailer: 1979 Boler B1700
Posts: 9,036
Quote:
Originally Posted by Sally P View Post
When my trailer is plugged in - quite a tight fit- the trailer brake lights glimmer even if the car is turned off. No other lights on and the brake lights turn off as soon as I disconnect. Is this normal? And is this draining the car battery?
This is definitely not normal. If the car does not provide power to the trailer connector when turned off, it may be coming from the trailer's battery due to an unwanted connection between pins of the connector on the car side... this would mean draining the trailer battery.
__________________

Brian B-P is offline   Reply With Quote
Old 06-02-2015, 10:23 AM   #13
Senior Member
 
Sally P's Avatar
 
Join Date: Jul 2013
Location: Auburn, California
Trailer: 2012 17B
Posts: 114
Thanks. I came home early from my trip (had an appointment at Escape this Wednesday for an inverter install) as the charging system wasn't working as expected and I didn't want to spend a week in a commercial campground for electricity with 4 dogs along! At least I know I'm not crazy....ummm, about the charging, anyhow.
Sally P is offline   Reply With Quote
Old 06-02-2015, 12:22 PM   #14
Senior Member
 
Seef's Avatar
 
Join Date: Mar 2014
Location: Leeuwarden, The Netherlands, Alabama
Trailer: 2014 Escape 5.0 Classic
Posts: 263
Quote:
Originally Posted by Brian B-P View Post
Those current European 13-pin plugs and sockets (ISO 11446) look like a nice system... but I would be very surprised to find one here.
Difficult but doable via webstores. Most of the stuff we need for the Escape is not available over here and we have to use all kinds of webstores to get our hands on it.

Quote:
Originally Posted by Brian B-P View Post
The pins and wires are relatively small in the Euro connections, in part because the power supply and ground are split between multiple circuits each, and in part because the electric brake connection is not used. Seef, you are using electric brakes on your Escape 5.0... are you using a non-standard pin assignment in your connector?
Yep, i do use electric brakes and to make things more complicated (well at least in this posting. ) i use not the 13 pin connection but the pre 1996 7 pin connector. . It is different to your 7 pin connector though. The fit is, most of the time, very snug.
Next to the 7 pin connector i use a separate 3 pin connector for the electric brakes. No thick wires though. Remember, needed to swap the axle for a EU type axle with electrical brakes.
Our electrical brakes work very different opposed to the US electrical brakes.

I'll try to make a photo of the connectors one of these days and post it over here.
__________________
Escape 5.0 classic (ARRIVED in Holland)
TV - ISUZU D-Max
Favorite destination (Europe) - Tuscany
Seef is offline   Reply With Quote
Old 06-02-2015, 05:48 PM   #15
Senior Member
 
Join Date: Dec 2012
Location: Edmonton, Alberta
Trailer: 1979 Boler B1700
Posts: 9,036
The Euro wiring topic is a sidetrack for this thread, so I started a separate thread: Wiring for Europe
Brian B-P is offline   Reply With Quote
Old 06-02-2015, 06:54 PM   #16
Senior Member
 
Join Date: Sep 2011
Location: Burlington, Ontario
Trailer: 2012 Escape 19
Posts: 193
Quote:
Originally Posted by yardsale View Post
Mine just pulled out once during a tight turn and the plug really got abraded by dragging on the pavement for 10 seconds or so. Now I wrap with duct tape.
Same thing happened to me two years ago after a u-turn in a parking lot. Sharp eyed fellow motorist noticed it dragging and singled me.

I've used (and reuse) a long twist tie to hold the cover latch protrusion into the trailers plug ever since
__________________
Robert
Burloak is offline   Reply With Quote
Old 06-02-2015, 10:18 PM   #17
Senior Member
 
bdornbush's Avatar
 
Join Date: Oct 2014
Location: Santa Rosa, California
Trailer: 2015 19 foot
Posts: 297
This was interesting to me. We just picked up our 19 last week and I noticed how loose the plug seemed. It was much looser than the one I had on my prior trailer. I'll have to watch it carefully. I hate to resort to a twist tie or duct tape or similar.
bdornbush is offline   Reply With Quote
Old 06-03-2015, 12:46 AM   #18
Senior Member
 
Join Date: Apr 2014
Location: Olympia wa, Washington
Trailer: 5.0TA 2017
Posts: 1,248
I have had this issue with my Escape and my horse trailer the plug is loose and sometimes it moves and I loose my lights have to check them all the time. I think I will try the twist tie or bungee to hold it secure
Fox hunt is online now   Reply With Quote
Old 06-03-2015, 06:26 AM   #19
Senior Member
 
Join Date: Jul 2012
Location: Burlington, Vermont
Trailer: 2014 17b/RAV4 (sold) 2012 Chevy Colorado
Posts: 421
I think I will change to the twist tie option over Duct tape.
yardsale is offline   Reply With Quote
Old 06-03-2015, 10:05 AM   #20
Site Team
 
Donna D.'s Avatar
 
Join Date: Nov 2008
Location: Portland, Oregon
Trailer: 2014 Escape 5.0 TA
Posts: 6,820
My situation is directly opposite. The plug is so tight, I really need to force the plug to make certain I get a good connection. It appears the Chevy folks have more issues with loose plugs than Ford folks?
__________________

__________________
Donna D.
Ten Forward
2014 Escape 5.0TA
Donna D. is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






» Virginia Campgrounds

Reviews provided by



All times are GMT -5. The time now is 04:15 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 Social Knowledge, LLC All Rights Reserved.