Hi, I'm a new Escape 5 owner - Escape Trailer Owners Community

Go Back   Escape Trailer Owners Community > Escape Community > New Member Introductions
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 07-10-2020, 09:12 PM   #1
Junior Member
 
Weavery's Avatar
 
Join Date: Jun 2020
Location: North Carolina, North Carolina
Trailer: 2002 19' Scamp
Posts: 5
Hi, I'm a new Escape 5 owner

Hi,
I've just sold my 19' Scamp and have been fortunate to purchase a 2016 Escape 5. I'm currently bringing it home from Washington State, where I picked it up at the Canadian border, to North Carolina.

I've been a member of the fiberglass rv forum (and will continue) and have found that community an invaluable resource. I'm looking forward to learning from you all.

So here is a starter question. When I turn on the built in radio, I smell ozone.
The rest of the trailer has been trouble free.
Thanks!
Jean
__________________

Weavery is offline   Reply With Quote
Old 07-10-2020, 09:50 PM   #2
Senior Member
 
escape artist's Avatar
 
Join Date: Oct 2008
Location: St. Thomas not BVI., Ontario
Trailer: 2014 Escape 5.0TA / 2016 Ram Eco Diesel 4X4
Posts: 6,771
Quote:
Originally Posted by Weavery View Post
Hi,
I've just sold my 19' Scamp and have been fortunate to purchase a 2016 Escape 5. I'm currently bringing it home from Washington State, where I picked it up at the Canadian border, to North Carolina.

I've been a member of the fiberglass rv forum (and will continue) and have found that community an invaluable resource. I'm looking forward to learning from you all.

So here is a starter question. When I turn on the built in radio, I smell ozone.
The rest of the trailer has been trouble free.
Thanks!
Jean
Hi: Weavery... Welcome!!! I can't comment as I don't have the "Ozone maker" option. Sounds like an airy rain fresh option though. Alf
escape artist N.S. of Lake Erie
__________________

__________________
Quote Bugs Bunny..."Don't take life too seriously, none of us get out of it ALIVE"!!!
'16 Ram Eco D. 4X4 Laramie Longhorn CC & '14 Escape 5.0TA
St.Thomas (Not the Virgin Islands) Ontario
escape artist is offline   Reply With Quote
Old 07-11-2020, 05:55 AM   #3
Site Team
 
cpaharley2008's Avatar
 
Join Date: Jun 2010
Location: Central, Pennsylvania
Trailer: Escape#4, 2019 Escape21 DejaView pulled by 2014 Ram Hemi/8sp
Posts: 22,790
Welcome Jean to out little Escape world. This is a new one, does the radio work properly, factory installed or owner installed, any pictures?
__________________
Jim
Sometimes life gets in the way of living......
cpaharley2008 is offline   Reply With Quote
Old 07-11-2020, 07:03 AM   #4
Site Team
 
padlin's Avatar
 
Join Date: Sep 2009
Location: Southwick, Massachusetts
Trailer: None, sold my 2014 5.0TA
Posts: 6,895
Welcome Jean. you made a good choice. I don't have a radio but I'd guess at the receiver going bad.

I did get mine stereo ready, the radio in my 2014 was designed to go under the upper cabinet just to the loft side of the entry door, is that where yours is? If so there may be a black wire loom running from the inside top to the bottom where the radio is, if so the 2 12vdc wires should be in it. You could see if they are getting hot. Chances are you smell burning plastic instead of ozone. To me, the small sounds like components inside the radio. The power wires are the only other thing I can think.

ETI runs a lot of the under cabinet wires for lights and such, inside the cabinet bottoms where you can't get to it without removing the device. That may be the case.
__________________
Happy Motoring
Bob
padlin is offline   Reply With Quote
Old 07-11-2020, 09:57 AM   #5
Junior Member
 
Weavery's Avatar
 
Join Date: Jun 2020
Location: North Carolina, North Carolina
Trailer: 2002 19' Scamp
Posts: 5
Thank you

The radio is a factory install. I will check the wires. It has a removable face, wonder if the problem is there and it can easily be replaced. This trailer has had almost no use since its original purchase. I was hoping it was just dust.
Jean
Weavery is offline   Reply With Quote
Old 07-11-2020, 10:10 AM   #6
Site Team
 
padlin's Avatar
 
Join Date: Sep 2009
Location: Southwick, Massachusetts
Trailer: None, sold my 2014 5.0TA
Posts: 6,895
I don't know how you remove the radio from it's holder, haven't done that since I was a kid. If you can figure it out you can vacuum it.
__________________
Happy Motoring
Bob
padlin is offline   Reply With Quote
Old 07-11-2020, 11:55 AM   #7
Senior Member
 
escape artist's Avatar
 
Join Date: Oct 2008
Location: St. Thomas not BVI., Ontario
Trailer: 2014 Escape 5.0TA / 2016 Ram Eco Diesel 4X4
Posts: 6,771
Quote:
Originally Posted by padlin View Post
I don't know how you remove the radio from it's holder, haven't done that since I was a kid. If you can figure it out you can vacuum it.
Hi: padlin...You just push the red "Eject" button!!! Gives you a complete face lift. Alf
escape artist N.S. of Lake Erie
__________________

__________________
Quote Bugs Bunny..."Don't take life too seriously, none of us get out of it ALIVE"!!!
'16 Ram Eco D. 4X4 Laramie Longhorn CC & '14 Escape 5.0TA
St.Thomas (Not the Virgin Islands) Ontario
escape artist is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Escape Trailer Industries or any of its affiliates. This is an independent, unofficial site.


All times are GMT -5. The time now is 03:48 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Copyright 2012 Social Knowledge, LLC All Rights Reserved.
×