Dead Outlets—What's Happening? - Escape Trailer Owners Community
Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×

Go Back   Escape Trailer Owners Community > Escape Tech > Problem Solving | Owners helping each other
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 02-21-2024, 08:53 PM   #1
Junior Member
 
Join Date: Jul 2018
Location: ELK RIVER, Minnesota
Trailer: 2018 5.0 TA
Posts: 26
Dead Outlets—What's Happening?

We are the original owners of a 2018 5.0 TA. The outlets for our microwave and below and to the right of the sink are dead. When we started our 10 day trip everything was working just fine. I squashed my 75 year old body into the space between the bench and the table. I couldn't see labels clearly while lying on the floor, but I turned each breaker on and off. No change, so I did it again. Those 2 outlets were still dead. Any idea of what's happening and how I can fix it.
Thanks in advance.
poodlespal is offline   Reply With Quote
Old 02-21-2024, 09:03 PM   #2
Senior Member
 
CharlesinGA's Avatar
 
Join Date: Jul 2021
Location: 50 miles S of Atlanta, Georgia
Trailer: 2008 BigfootRV 25B21RB
Posts: 289
Have you checked and reset your GFCI outlet? Its either the outside outlet, or the bathroom outlet. If your outside outlet it dead, the GFCI tripped is almost for certain the problem.

Charles
__________________
'03 Ram 2500 CTD, 5.9HO PacBrake six speed std cab long bed Leer top and 2008 Bigfoot 25B21RB.. Previously, 2008 Thor Freedom Spirit 180, SOLD! 2007 Winnebago View 23H Motorhome, SOLD!
CharlesinGA is offline   Reply With Quote
Old 02-22-2024, 08:43 AM   #3
SRS
Senior Member
 
Join Date: Jul 2021
Location: Grand Junction, Colorado
Trailer: 2022 Escape 17A, 2021 F-150 3.5L Ecoboost
Posts: 256
Quote:
Originally Posted by poodlespal View Post
We are the original owners of a 2018 5.0 TA. The outlets for our microwave and below and to the right of the sink are dead. When we started our 10 day trip everything was working just fine. I squashed my 75 year old body into the space between the bench and the table. I couldn't see labels clearly while lying on the floor, but I turned each breaker on and off. No change, so I did it again. Those 2 outlets were still dead. Any idea of what's happening and how I can fix it.
Thanks in advance.
If you have an inverter, there is a transfer switch under the bench behind the power center with a couple of breakers. Check those. In my trailer it's the grey box at the back of the bench.
Attached Thumbnails
Power Transfer Switch.jpg  
SRS is offline   Reply With Quote
Old 03-06-2024, 02:30 PM   #4
Junior Member
 
Join Date: Jul 2018
Location: ELK RIVER, Minnesota
Trailer: 2018 5.0 TA
Posts: 26
Thanks for your feedback.
poodlespal is offline   Reply With Quote
Old 03-06-2024, 02:31 PM   #5
Junior Member
 
Join Date: Jul 2018
Location: ELK RIVER, Minnesota
Trailer: 2018 5.0 TA
Posts: 26
Thanks for getting back to me so quickly, I think that is the problem.
poodlespal is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Escape Trailer Industries or any of its affiliates. This is an independent, unofficial site.


All times are GMT -5. The time now is 07:21 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
Copyright 2023 Social Knowledge, LLC All Rights Reserved.